Outlook 2007 remember password checkbox is missing

We recently moved from in house Exchange 2003 to hosted Exchange 2007. The new Outlook profiles we created use owa over https using basic authentication. We unchecked the box in Outlook settings to always prompt for password on login. All computers are running Windows 7 with Outlook 2007. After the migration to hosted Exchange with all computers using the same Outlook profile settings, some computers had Outlook with the Remember my Password check box so they dont have to type their Excahnge username and password every time, while on others the check box has gone, and so they have to type in the password every time. I've checked service packs and updates on Office and Windows and I can't work out why on some machines the box has gone and on others it's there and works fine. All with the same settings!
Any and all suggestions/solutions welcome!
Who is Participating?
Madan SharmaConsultantCommented:
you can set both type of authentications by using Set-owavirtualdirectory cmdlet through PowerShell
in order to bypass that screen you will need to change the auth settings for outlook anywhere from basic to ntlm.  being hosted exchange maybe this is not possible, thats just what I have noticed working with exchange 2010 so far.
pturner_edowAuthor Commented:
Right, but the host doesn't support ntlm authentication. Some of the Outlook clients have the checkbox and it works fine with the basic setting, so I believe there's something else that's making this happen.
its a microsoft thing, and it shouldn't work for any clients.  I have seen this before and nothing fixed it that I have tried, but I have heard that there may be a registry hack to get around it.  would take some googling.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.