[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 649
  • Last Modified:

Problem with Exchange 2007 in SBS 2008 enviorment


I recently installed SBS 2008 on a new server, everything installed smoothly according to WSUS system is up to date and everything seems to be working fine.
I configured everything through the wizards, I let sbs 2008 take over my godaddy account and the configurations were auto.
I can receive emails there are no problems with that, however when it comes to sending email nothing goes out, I can only send internal emails, for external mail delivery i get the following email with error msg hours later:

Status: 5.4.0
X-Supplementary-Info: < #4.4.7 smtp;400 4.4.7 Message delayed>

I really dont know what is happening, im not a technician but ive hired two guys and none of the two were able to figure out the problem.
Could someone guide me on to troubleshooting this problem?
0
jorgeprince
Asked:
jorgeprince
  • 13
  • 11
  • 5
  • +2
2 Solutions
 
RickEpnetCommented:
I understand if you do not want to post this information but it would be easiest and fastest if you could give us the domain name.

0
 
jorgeprinceAuthor Commented:
sorry! i forgot to mention that,  it is...   primosa.net    
if I am missing any other info im happy to provide.  Sbs configured the domain to remote.primosa.net
0
 
5g6tdcv4Commented:
mxtoolbox.com has several tools that will help you troubleshoot this....

You are running on a dynamic ip for one....

reverse dns is not matching up.....

Is your banner being masked?
Capture.JPG
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Neil RussellTechnical Development LeadCommented:
The reverse dns lookup returns
Name:    189.222.94.186.dsl.dyn.telnor.net
Address:  189.222.94.186
0
 
5g6tdcv4Commented:
reverse dns is not matching up.... with the smtp banner
0
 
jorgeprinceAuthor Commented:
that is odd, I have a mexican ISP provider, and i recently changed to a static ip, i have a smarthost through dyndns i thought i could avoid reverse dns with that? i had configured smarthost through the wizard but mail still stays in the queue.
I dont know if my banner is being masked, how can i solve that?  
0
 
5g6tdcv4Commented:
you cant avoid rdns
http://community.mxtoolbox.com/forums/viewtopic.php?f=8&t=13170 read on how to check for banner masking
0
 
jorgeprinceAuthor Commented:
after i change the banner to match my domain, how to I put it in my PTR records?
0
 
5g6tdcv4Commented:
Neil can you assist? I am at a birthday party... Mine
0
 
RickEpnetCommented:
Unless you manage the DNS and reverse DNS you cannot. You need to contact your ISP and they will put in the RDNS.

You see when you do a reverse look up of your IP address 189.222.94.186 is comes out to this.
189.222.94.186.dsl.dyn.telnor.net

It should come out to this.
remote.primosa.net

You need to get your ISP to make this change.

As far as your Smart Host have you tried Telneting in from the server to that Smarthost to make sure you can get a good connection?
0
 
RickEpnetCommented:
Here are some good instructions for testing with Telnet.

http://www.ehow.com/how_6914508_test-smtp-host.html
0
 
jorgeprinceAuthor Commented:
I called my ISP, they cannot make the change on their end according to their policy. Is there a way to set up a mail server without having a rdns?
Thanks Rick I will try telneting my smart host I will get back with the results.
0
 
RickEpnetCommented:
You do not need the RDNS to send the mail but you may have issues with your mail getting marked as SPAM. But it is not that big of deal I have several customers that do not have the RDNS and they really do not have any issues.

I think your issue is with the Smarthost. Why are you using a Smarthost?
0
 
jorgeprinceAuthor Commented:
Well I figured that having a smart host I wouldnt have any problems with the RDNS, here's what ive done:
I set up SBS 2008 all through wizards and let it take over my go daddy account so it points dns records to itself, I logged in to go daddy just to double check everything is configured correctly which I think it is.
I do receive email, however, im not able to access remote desktop (i will make another thread about this when I solve my mail issue), I did open up the ports on the router and forwarded them to the server. I have exchange 2007 sp3 (havent installed latest rollup though) so basically the server did all the configuration by itself. I dont mind not using a smat host i just thought everything would be much easier. This is the error that I get.

Diagnostic information for administrators:

Generating server: SSSRV.securespot.local

jorgeprince@gmail.com
#550 4.4.7 QUEUE.Expired; message expired ##

Original message headers:

Received: from SSSRV.securespot.local ([fe80::281a:d866:206:4574]) by
 SSSRV.securespot.local ([fe80::281a:d866:206:4574%10]) with mapi; Thu, 6 Oct
 2011 23:26:17 -0700
From: Jorge Prince <jpg@primosa.net>
To: Jorge Prince <jorgeprince@gmail.com>
Date: Thu, 6 Oct 2011 23:26:15 -0700
Subject: test
Thread-Topic: test
Thread-Index: AcyEugPwZFgtHtxZRCKqG2k88vpN+Q==
Message-ID: <0EB940E2ACEA7C49BABDDC4129BB0FCC17A02D05@SSSRV.securespot.local>
Accept-Language: en-US
Content-Language: es-ES
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/alternative;
      boundary="_000_0EB940E2ACEA7C49BABDDC4129BB0FCC17A02D05SSSRVsecurespot_"
MIME-Version: 1.0

Before the msg expired it was error code:  

5.4.0 X- Supplementary-info: < #4.4.7 smtp;400 4.4.7 Message delayed>

Ive tried sending mail to yahoo, gmail, hotmail, even private domains from our clients and our mail does not get delivered, it must be something wrong with my server that mail is never even leaving the domain.
0
 
5g6tdcv4Commented:
Do you have send connectors configured?
If you run BPA does it throw any errors?
0
 
pmckenna11Commented:
I would not think that the rdns issue is the root of your problem. In my experience it has caused an email here or there to bounce but I generally will see a nondeliverable error messge from the receiving server. In any case at least some emails would be delivered. it looks as if none of yours are making it out at all. Couple of thoughts
1. Is the SMTP port you are using either misconfigured on the server or somehow blocked by a firewall?
2. If you are using port 25 is your ISP blocking that port? It is fairly common that port 25 is blocked in which case you would need to change it?
3. Can you completely bypass the smarthost for now? It seems that a misconfiguration there could be the problem. Or perhaps is there a way to check to see if the email is at least reaching the smarthost? Any technical help available from them?
4. Also I have had a LOT of problems with Exchange 2007 installations that were not up to date. Are you sure you have SP3 installed? Might not hurt do download and install the latest rollup if all else fails.
5. Also definetly run BPA
0
 
jorgeprinceAuthor Commented:
Thanks a lot every1 for your help im pulling my hair out here. To answer everyone's questions:

I forwarded port 25 from the router to the server.
I have a static IP with port 25 open from my ISP, I tested on  testexchangeconnectivity.com and mxtoolbox.com and oddly enough test from the first site pass, i only fail the certificate validation test but thats cause i havent installed one, mxtoolbox just says that my smtp banner does not match my domain.
Yes I can ditch the smart host, I just want my mail to at least make it out of my domain.
Yup, I deployed the sp3 from wsus, did the install and rebooted, i just need to install the latest rollup.

How can I check how port 25 is configured on the server?
I agree with you pmck I also think my emails are not even going out, maybe some service in the sbs 2008 enviorment interfering with exchange?
I will run BPA and get back with the results.
0
 
RickEpnetCommented:
I still think it is an issue with your Smarthost. Have you tried do ditch Smarthost just as a test. If you email goes out without the Smarthost that will narrow things down.
0
 
jorgeprinceAuthor Commented:
Yes, at first i didnt have a smarthost and had the same error, i read somewhere that it might be the rdns issue so thats why I went with dyndns and still mail is not being delivered. Now I really dont mind if I use it or not I just want to get my mail delivered.
I really dont know what Im doing here but all your input has been really helpful, I will run the BPA and see what pops up.
I though installing and running SBS 2008 would be really easy just like it was intended to be, but it is not, at least not for me.
0
 
RickEpnetCommented:
It normally is easy.

Have you change the IP address of the sever since it was installed?
Is the IP address an internal IP address like 192.168.1.x or 10.10.x.x?
What do you have in the DNS entry on the network adapter on the SBS server? Is it the same IP address as the SBS itself?
0
 
pmckenna11Commented:
Dump the smart host for now then test. If it doesn't work check/change the current smtp port on the send connector (should probably just be the default SBS connnector since you have been using the wizard).

Here are two links that will probably help

http://www.computerperformance.co.uk/exchange2007/exchange2007_smtp_connector.htm
http://www.exchangelog.info/2007/08/how-to-change-smtp-port-25-in-exchange.html

I think there is enough info in the above links so you can figure out how to remove the smarthost and check/set the outgoing smtp connector.

Like Rick I think it is probably something with your smarthost.......

BTW running your own Exchange server is great until something goes wrong then it just sucks unless that is all you do for a living!
0
 
jorgeprinceAuthor Commented:
Would it make a difference if I told you that SBS 2008 server is not the DHCP? I have a 2wire router and it is very difficult to set it up on bridge mode, when I tried the router woudlnt connect through PPPoE, long story made short, I left the router as DHCP and disabled the one on the server and just assigned static ip addresses to everything.... id hate to think that is the root of my exchange problem.
0
 
RickEpnetCommented:
I have never gotten a DSL 2wire to work in Bridge mode. And yes it make a big difference but it should not for this issue.

Let's get back to DNS. Is the IP address of the server a private IP address or Public? Is the IP address in the DNS section of IPv4 the same as the SBS Server's IP address?
0
 
RickEpnetCommented:
Here is a screen shot that might help.
10-13-2011-4-34-40-PM.jpg
0
 
jorgeprinceAuthor Commented:
here is a screenshot of my screen,  I think everything is ok in that area
server.jpg
0
 
jorgeprinceAuthor Commented:
lol screenshot of my screen... omg im just so tired
0
 
RickEpnetCommented:
Have you tried taking out the Smart Host?
0
 
pmckenna11Commented:
From your posted error message

Diagnostic information for administrators:
Generating server: SSSRV.securespot.local


Is SSSRV.securespot a server at your smarthost?

And I am not getting why you are doing DHCP on the router and why you even wanted to try and setup bridge mode on the router. Anyway best practice is always to let your SBS box do everything.  Why don't you just turn off DHCP on the router and let the server take care of it. Don't know why it would cause the problem but SBS is quite complicated under the hood. When you vary from any of the defaults you can quickly run into odd problems. Also from the sound of it you might even want to consider setting the router back to factory defaults and starting over with it


And about getting rid of the smarthost (temporarily) and running BPA as suggested........?
0
 
jorgeprinceAuthor Commented:
ok, im not using smarthost.... i took that out since the first time you guys suggested, the reason y i have the router/modem on DHCP is because I cant get it to work properly on bridge mode and the router wont connect through pppoe with the 2wire device on bridge mode, so i just gave up and left it as dhcp and turned off dhcp on the server and manually assigned ip's.

you'll probably think im very bad at this but i dont understand the reports the BPA throws out, is there a way I can export the report and attach it here? Another IT guy is coming tomorrow to help, I hope he can fix this.
0
 
jorgeprinceAuthor Commented:
i have a 2wire att modem/router... in order to make the server dhcp I have to set the 2wire device in bridge mode and connect to my isp through another router and turn off dhcp on that router, if the 2wire device connects to the ISP it will not let you disable dhcp unless you enable bridge mode, ive searched for tutorials tried them all and it didnt work...
0
 
RickEpnetCommented:
I am not sure what the issue is.

But if you want to run the 2Wire in Bridge mode you have to get ATT help with their second level support most likely.

Have you checked to see if ATT is blocking Port 25 traffic?
0
 
RickEpnetCommented:
Never mind about port 25.

Does the non-delivery notice look the same after disabling the smart-host?
0
 
jorgeprinceAuthor Commented:
yes it looks the same... tomorrow ill attach the BPA report
i havent had time to work on the server, but tomorrow ill focus on it and post all the tests you guys suggested
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 13
  • 11
  • 5
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now