• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7325
  • Last Modified:

Skip User oobe & machine oobe windows 7 x64 answer file

How to skip User oobe & machine oobe in windows 7 x64 answer file. we are in process of creating image for Win7 x64. The same function is achived in 32bit but cannot be in 64bit. we are using WAIK/ImageX....
e.g: <SkipMachineOOBE>true</SkipMachineOOBE>                 <SkipUserOOBE>true</SkipUserOOBE>
This works in 32bit but not in 64bit.
How to skip both in 64bit.
0
shahzamm
Asked:
shahzamm
  • 4
  • 4
1 Solution
 
footechCommented:
Both the SkipMachineOOBE and SkipUserOOBE settings are deprecated, don't use them.  See here as a reference:
http://technet.microsoft.com/en-us/library/ff716016%28WS.10%29.aspx

If you don't want any part of the OOBE to show up, you will need to specify the all the answers to the questions it asks in the answer file.
0
 
shahzammAuthor Commented:
we tried this one. but we do not want any user to be specified. we enabled the default administrator account to login initially.
0
 
footechCommented:
I'm not sure I understand the problem.  Are you saying that you're still getting a prompt to create a new user account?  Use the below in your answer file:
            <UserAccounts>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <DisplayName>Administrator</DisplayName>
                        <Group>Administrators</Group>
                        <Name>Administrator</Name>
                        <Description>Built-in account for administering the computer/domain</Description>
                    </LocalAccount>
                </LocalAccounts>
            </UserAccounts>

When you use "LocalAccount" to add an account but specify Administrator as the user, it activates the built-in administrator account.  If you don't want some other account created, this is the only way to do it.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
shahzammAuthor Commented:
your understanding is right.
but adding this pop error. The computer cannot parse XXXXXXXXXXXXXXXXXXX.
0
 
footechCommented:
How did you add the above to your answer file?  You should use the the WSIM in the WAIK to create your answer file.  The above was just meant as a guide of what to enter when using the WSIM.

Under the component "Microsoft-Windows-Shell-Setup", dig down to UserAccounts>LocalAccounts>LocalAccount, right-click and add to pass 7.  Then use the info above to fill in the entry for DisplayName, Group, etc.
0
 
shahzammAuthor Commented:
it was added through image manger in waik. not through xml file.

what we did is, kept admin account disabled & defined as above in WSIM
0
 
footechCommented:
Is the error you're seeing exactly as above?

If you post your answer file I can take a look at it.  Also, make sure that the answer file was built for the correct architecture (x86 or x64).
0
 
shahzammAuthor Commented:
Thanks
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now