• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 269
  • Last Modified:

need to reset permissions to server 2003 disk

Hello everyone, I having a horrible time resetting permission on our file server.
I need to migrate data off it.
Ther permissions are all jacked up. I have had serveral ppl help me wiht it, but nobody can figure it out.
The perms are not resetting themselves.
I need a way to reset permissions on a whole disk.
With a gui please, I'm not that smart. Is there a 3rd party tool out there to reset it back to original?
0
Russoxley
Asked:
Russoxley
  • 3
  • 2
  • 2
  • +2
1 Solution
 
pedrohgeraldesCommented:
Just need to click on properties, security and then in advanced in the lower tab.
On the advanced you have to remove all the users from the secuity it will give you a warning concerned to the disk or file will be without any owner but dont worry, then you go into the same tab and put the owners that you want that thisk to have.
0
 
RussoxleyAuthor Commented:
done that a 1000  times...
Its about a tb worth of data.
And you can not replace the children. Dont work.
0
 
pritamduttCommented:
Try this
Download and Install XCacls.vbs from http://download.microsoft.com/download/f/7/8/f786aaf3-a37b-45ab-b0a2-8c8c18bbf483/xcacls_installer.exe
and run

xcacls.vbs D:\ /g domain\testuser1:f /f /t /e

Open in new window


Hope this helps
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
celazkonCommented:
Log in as administrator. Go to properties of the disk, choose the security tab and click on the advanced button.
Check the owner tab. If the actual owner is not Administrators group, add it and check the replace owner checkbox. Then click apply to change the owner of whole disk. This opperation can take long time, depending on the ammount of data on disk, be PATIENT.

After this, change to the permissions tab and remove everything in the list, DON'T click apply yet, and add:
Administrators - full control for this folder, subfolders & files
system - full control for this folder, subfolders & files
creator owner - full control for Only subfolders & files
everyone - traverse folders, read folder content, read attributes, read extended attributes, read permissions for Only this folder
users - traverse folders, read folder content, read attributes, read extended attributes, read permissions for this folder, subfolders & files
users - create folders for this folder & subfolders
users - create files for Only subfolders

Check the replace permissions on all child objects checkbox and click apply. This will take long time, depending on the ammount of data stored on the disk. After this is done, you should be okay.
0
 
RussoxleyAuthor Commented:
still access denied. I even am taking ownership of the entire disk.
This is outrageous
0
 
pritamduttCommented:
I'll suggest you to run Chkdsk on the specified disk once and retry taking ownership...

Please note the following command will dismount the volume first.

CHKDSK /R /F /X 

Open in new window


Hope this helps
0
 
RussoxleyAuthor Commented:
It's a vm. Does that change anything?
0
 
celazkonCommented:
If the checkdisk doesn't help, I would recomend to turn the VM off and add it's drive to another functional VM (must also be turned off prior to adding drive) and do the changes I described earlier on the other VM computer.
0
 
ddawesCommented:
I found when I had a similar issue that I needed to actually browse to the specific Folder/File that was locked down and had to complete the above steps.  The only difference to the above is that I needed to apply the OWNER permissions first, close the properties dialog and then reopen it to apply the security changes.  When I did a apply owner/permissions at a high level, it still didn't reapply correctly.

Sometimes the file may also have the apply permissions from parent unticked and by ticking it and applying to its subfolders/files also resolved the issue.

Hope this helps.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now