?
Solved

Cisco IP Phones not going to the correct VLAN on Procurve switche

Posted on 2011-10-09
17
Medium Priority
?
1,911 Views
Last Modified: 2012-05-12
I have 4 switches. 2 Cisco and 2 Procurve. 2 VLANs one for voice and one for data. One DHCP for each VLAN. The setup is like this:

Computer-----IPPhone----switch.

On the Cisco switches handle this well. The computer gets an IP from data dhcp and the phone gets an IP from the voice DHCP.

This doesn't work at all from the Procurve switches. The phones and the computer get IPs from the data DHCP.

Config attached.

Thanks for any clues.
Running configuration:

; J9022A Configuration Editor; Created on release #N.11.25

interface 1 
   name "to 1st" 
exit
ip default-gateway 10.65.2.1 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 1-48 
   ip address 10.65.2.3 255.255.0.0 
   qos priority 0 
   exit 
vlan 100 
   name "voice" 
   ip address 10.1.1.3 255.255.255.0 
   qos priority 6 
   tagged 1-48 
   voice 
   exit 
lldp enable-notification 1-48 
ip ssh

Open in new window

0
Comment
Question by:michaeltegler
  • 9
  • 3
  • 2
  • +3
17 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 36939523
Could it possibly be a setting on the phones? What is your admin vlan set to on the phones?
0
 

Author Comment

by:michaeltegler
ID: 36939585
I don't understand why it would work for the Cisco switches and not the ProCurve.

I don't have an option on the phone itself to set the VLAN. It's the Cisco IP Phone 303.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36939615
Where are you managing the phone from? This may be where you need to specify that information.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:michaeltegler
ID: 36939839
I have a UC320, which is the DHCP for the voice VLAN. It is specified there.
0
 
LVL 6

Expert Comment

by:Sanjeevloke
ID: 36941498
How is connectivity between switches ?
have u used trunk between procure and cisco ?

0
 

Author Comment

by:michaeltegler
ID: 36942229
Yes trunking has been set up between switches. Connectivity is good. I've used different cables and different ports.
0
 
LVL 4

Accepted Solution

by:
dcj21 earned 1500 total points
ID: 36942244
I would agree. Since the Data VLAN is the default, without trunking the procurve only can serve vlan 1 DCHP

The ProCurve configuration looks good, but what about the Cisco? and what port  is the trunk port(connection between)?

Here's an HP document on using Cisco & ProCurve switched for phones.
http://www.tecnocael.it/ftp/docs/ProCurve_Cisco.pdf

If you are still having issued, please upload a sanitized version of the full configs.

0
 

Author Comment

by:michaeltegler
ID: 36944466
Thanks. I had to pull the ProCurves offline while I researched this. I'm going to review this PDF and make sure I have the trunks set up correctly. We get back ASAP
0
 
LVL 37

Expert Comment

by:ArneLovius
ID: 36983012
Presuming that your phones are not statically configured...

With a HP switch you will need to to set the DHCP server on the PC subnet to have the correct options for the Cisco phones to tell them that they need to be on VLAN 100, this information might also need to be present on the DHCP server on VLAN 100.
0
 

Author Comment

by:michaeltegler
ID: 36995965
I followed the instructions in the document linked by dcj21. still no joy. seems to be a rather straight-forward config.
0
 

Author Comment

by:michaeltegler
ID: 36996015
here's the port config on the cisco side:


Name: Gi0/17
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Open in new window

0
 

Author Comment

by:michaeltegler
ID: 36996364
Also I'm getting "Excessive CRC/Alignment Errors on port 5" this is where the phone is plugged into
0
 
LVL 4

Expert Comment

by:dcj21
ID: 36996498
Those errors could be from a misconfigured port speed or duplex mismatch, bad cable, or bad phone.

Not used to seeing the config that way on a cisco, but it looks ok  can you get the output from a sh run  or  sh run int gi0/17 ?

Is VLAN 100 defined on the Cisco?  sh vlan
I think Voice VLAN: none  should be Voice VLAN: 100
0
 

Author Comment

by:michaeltegler
ID: 37000190
Those errors show up no matter what phone, cable or port I try. If I plug the same cable/phone into the Cisco switch it shows no errors. The only time they don't show up if plug in a regular computer.

Made the Voice VLAN: 100

Still no joy. Could something in the Cisco be blocking the trunking?

Here;s the full config
version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Core-3560G-SW
!
logging buffered 20000 notifications
enable secret 5 $1$N8dP$feY/PreqDkGrKP1OMc3Zv/
!
username gt_tech privilege 15 secret 5 $1$bEZI$GKFV/Lh8wOjLUtae9weOj.
username admin privilege 15 password 7 0256144F020901747E
username jandersen privilege 15 password 7 055F575870181F
aaa new-model
aaa authentication login default local enable
!
aaa session-id common
clock timezone UTC -6
clock summer-time UTC recurring
ip subnet-zero
no ip source-route
ip routing
no ip gratuitous-arps
no ip domain-lookup
!
ip igmp snooping vlan 1 immediate-leave
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
errdisable recovery cause storm-control
errdisable recovery interval 30
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,777 priority 4096
!
vlan internal allocation policy ascending
!
interface Port-channel1
 description Uplink to 2FloorW-2960-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 description Mercury Server Port-Channel
 spanning-tree portfast
!
interface Port-channel10
 description Uplink to 1stfloor3-3524-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel20
 description Uplink to 1stfloor2-3524-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel30
 description Uplink to creative-3524-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast trunk
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/3
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/4
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/5
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/6
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/7
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/8
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/9
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/10
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast trunk
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/12
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/13
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/14
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/15
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/16
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast
 spanning-tree link-type point-to-point
!         
interface GigabitEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/19
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/20
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/21
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/22
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/23
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/24
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/25
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/26
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/27
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/28
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/29
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/30
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/31
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/32
 switchport mode access
 switchport voice vlan 100
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/33
 spanning-tree portfast
!
interface GigabitEthernet0/34
 spanning-tree portfast trunk
!
interface GigabitEthernet0/35
 spanning-tree portfast trunk
!
interface GigabitEthernet0/36
 spanning-tree portfast
!
interface GigabitEthernet0/37
 spanning-tree portfast
!
interface GigabitEthernet0/38
 spanning-tree portfast
!
interface GigabitEthernet0/39
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast trunk
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/40
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 spanning-tree portfast trunk
!
interface GigabitEthernet0/41
 switchport mode access
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/42
 spanning-tree portfast
!
interface GigabitEthernet0/43
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast trunk
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/44
 spanning-tree portfast trunk
!
interface GigabitEthernet0/45
 description Mercury - 10.65.1.11
 channel-group 2 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/46
 description Mercury - 10.65.1.11
 channel-group 2 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/47
 description Mercury - 10.65.1.11
 channel-group 2 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/48
 description Mercury - 10.65.1.11
 channel-group 2 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/49
 spanning-tree portfast
!
interface GigabitEthernet0/50
 spanning-tree portfast
!
interface GigabitEthernet0/51
 description Uplink to 2FloorW-2960-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet0/52
 description Uplink to 2FloorW-2960-SW
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!
interface Vlan1
 ip address 192.168.10.3 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan100
 ip address 10.1.1.2 255.255.255.0
!
interface Vlan777
 description TEST VLAN 777
 ip address 172.16.10.1 255.255.255.0
 ip helper-address 10.65.1.5
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!         
ip classless
ip route 0.0.0.0 0.0.0.0 10.65.1.1
ip route 0.0.0.0 0.0.0.0 192.168.10.2
no ip http server
ip http secure-server
!
radius-server source-ports 1645-1646
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 access-class 23 in
 exec-timeout 0 0
 privilege level 15
 password 7 124915031B04025118
 logging synchronous
 login authentication local
line vty 5 15
 access-class 23 in
 privilege level 15
 password 7 101E190D0C181C5E3E
 logging synchronous
 login authentication local
!
ntp clock-period 36029399
ntp server 192.5.41.40 key 0 prefer
end

Open in new window

0
 
LVL 4

Expert Comment

by:GarethPeart
ID: 37000772
I was having some similar issues here. After searching for a while, I found this , which helped in my situation.
0
 
LVL 4

Assisted Solution

by:dcj21
dcj21 earned 1500 total points
ID: 37001814
I dont see any issues. Might be time to do a debug to see what's going on.
0
 

Author Closing Comment

by:michaeltegler
ID: 37273444
I've given up trying to get these switches to talk to each other. I'm making do with just Cisco switches. Thanks to all for the help.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Suggested Courses
Course of the Month13 days, 20 hours left to enroll

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question