Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

running bootcamp and now created 3rd disk and Windows 7 wont boot

Posted on 2011-10-09
22
Medium Priority
?
779 Views
Last Modified: 2012-05-12
I have Bootcamp on Macbook Pro and have been running with two partitions with Mac on one and Windows on another.

Now I decided to create a third disk to keep my data on. All worked fine and I can store files etc on this new partition. I can also see the Windows 7 partition.

When I reboot the Mac I get a black screen and a message indicate that non-boot disk found. Rebooting and holding the ALT key down gives the ability to boot into Mac again.

I found the following articles that suggest that I need to edit the Boot.ini file and change the partition number to be able to boot into Windows.

However, I Windows 7 no longer has a Boot.ini.

http://davidseah.com/wikilab/Creating-2-Windows-Partitions-with-Boot-Camp/

Has anyone got experience on this?

How can I fix this replacement for boot.ini from MacOS?

This article suggested installing rEFIt (http://refit.sourceforge.net/) to fix the issue.
http://forums.macrumors.com/showthread.php?t=264754

Anyone have experience on using rEFIt on bootcamp with three partitions on the Mac?

Thanks
0
Comment
Question by:sunspots2002
  • 16
  • 6
22 Comments
 
LVL 15

Expert Comment

by:roylong
ID: 36941462
rEFIt works like a charm - I use it to triple boot win mac linux.
That should sort out your issue for sure.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36945576
I installed rEFIt but on reboot it tried to boot WIndows (my default selection from Bootcamp) and gave me "No bootable device -- Insert boot disk and press any key".

I rebooted and held ALT key down which gave me the choice of Mac or the restore disk.

This suggests to me that rEFIt hasn't been installed correctly. I couldn't see anything on the web site for configuring, everything to me suggested it installs and works.

I'lll try and re-install, while I hope you can provide me with further guidance.

Thanks
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36945603
I did ran the Partition Inspector. Maybe this has some clues. Let me know if any further information is required.


*** Report for internal hard disk ***

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1             40       409639  EFI System (FAT)
 2         409640    488008255  Mac OS X HFS+
 3      488008256    489277799  Mac OS X Boot
 4      489279488    585664511  Basic Data
 5      585664512    976773119  Basic Data

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1       409639  ee  EFI Protective
 2         409640    488008255  af  Mac OS X HFS+
 3      488008256    489277799  ab  Mac OS X Boot
 4      489279488    585664511  07  NTFS/HPFS

MBR contents:
 Boot Code: Unknown, but bootable

Partition at LBA 40:
 Boot Code: None (Non-system disk message)
 File System: FAT32
 Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
 Boot Code: None
 File System: HFS Extended (HFS+)
 Listed in GPT as partition 2, type Mac OS X HFS+
 Listed in MBR as partition 2, type af  Mac OS X HFS+

Partition at LBA 488008256:
 Boot Code: None
 File System: HFS Extended (HFS+)
 Listed in GPT as partition 3, type Mac OS X Boot
 Listed in MBR as partition 3, type ab  Mac OS X Boot

Partition at LBA 489279488:
 Boot Code: Windows NTLDR
 File System: NTFS
 Listed in GPT as partition 4, type Basic Data
 Listed in MBR as partition 4, type 07  NTFS/HPFS

Partition at LBA 585664512:
 Boot Code: Windows BOOTMGR (Vista)
 File System: NTFS
 Listed in GPT as partition 5, type Basic Data

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:sunspots2002
ID: 36945653
I re-installed rEFIt and did a reboot. Prior to the re-install I went to the bootcamp Startup Disk and choose Apple. Did the re-install and rEFIt re-installed successfully. But the reboot just booted into MacOS.

I tried to look in the application and utilities folders but cannot find rEFIt.
0
 
LVL 15

Expert Comment

by:roylong
ID: 36945905
You should get an alternate boot menu.  Refit is at /efi - the root of hard drive, access via Terminal.

Below from the docs:

Here are the steps for a manual install:
Download the “Mac disk image” or any of the other two binary distributions from the home page. Double-click to mount or unpack them.
Copy the “efi” folder from the rEFIt distribution to the root level of your Mac OS X volume.
Open Terminal and enter the following commands:
cd /efi/refit
./enable.sh
When prompted, enter the password for your user account.
If everything went well, you’ll see the rEFIt boot menu on the next restart.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36945927
After posting the last update, I shut down the system and went away for an hour or so. On my return I started the system and was welcomed with the rEFIt menu.

I choose MacOs, it booted okay. Then tried each of the Windows icons. The first one gave a black screen with the cursor blinking in the top left corner. The second Windows icon gave a black screen with "No bootable device -- Insert boot disk and press any key".

I guess the Windows icon associated to the message "No bootable device" should be the Windows 7 bootable drive.

How do I resolve this to get rEFIt to boot?
Thanks
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36945934
Hi roylong,

Just saw your comments. I didn't need to do your proposal as it did finally boot up with the rEFIt menu.

Any help on getting Windows 7 now to actually boot would be greatful.

Thanks
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36946665
I wanted to have the bootcamp partition available in a virtual machine. So, I decided to download vmWare Fusion to get the bootcamp into Fusion to allow me to continue using Windows while I sort out the issue of booting into Windows from bootcamp.

On starting up Fusion the option to create a virtual machine from Bootcamp tells me that no bootcamp partitions found.

This suggests that creating the third disk from the MacOS has destroyed some pointers or something.

Hope this gives more details on what the problem might be and how I can fix the booting of Windows 7 from bootcamp partition, either by rEFIt or the Apple tool of bootcamp.
0
 
LVL 15

Expert Comment

by:roylong
ID: 36949849
That does sound like something got screwed up when you created the data disk - how did you create the disk?  Did you use the macintosh command line tools; if you did it from Windows then this may well have caused an issue.

I would recommend booting from a Windows repair disk - you can do this through rEFIt - and see what this can find on your system.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36960492
Tried the Windows repair disk and no joy,

Went to the command line and executed "bootrec /fixmbr", also other commands for bootrec, like /FixBoot, & /RebuildBcd

Also tried GPARTED to look at the HDD. A friend tried different commands to get to the boot block, without any success.

Noted that only 4 partitions appear when listed, when there should be 5. The fifth partition is the Windows 7 (bootable partition). The 4th partition that is listed in my earlier comments is the 50gig partition I created to store documents.

He mentioned that the MBR is compressed and if it wasn't it should then be visible.

The partition is showing as compressed in OSX in GPT table. But not showing up in the MBR table.

What I've been told, that if it is possible to mark the partition as uncompressed then it should be possible to create the MBR entry.

Doing a "diskutil info /dev/disk0s5" gives the following information

   Device Identifier:        disk0s5
   Device Node:              /dev/disk0s5
   Part of Whole:            disk0
   Device / Media Name:      BOOTCAMP

   Volume Name:              Windows7
   Escaped with Unicode:     Windows7

   Mounted:                  Yes
   Mount Point:              /Volumes/Windows7
   Escaped with Unicode:     /Volumes/Windows7

   File System Personality:  UFSD_NTFS_COMPR
   Type (Bundle):            ufsd_NTFS
   Name (User Visible):      Windows NT Filesystem (compressed)

   Partition Type:           Microsoft Basic Data
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              0B9476C0-2076-4908-85F5-464A8579AE17

   Total Size:               200.2 GB (200247607296 Bytes) (exactly 391108608 512-Byte-Blocks)
   Volume Free Space:        113.7 GB (113670348800 Bytes) (exactly 222012400 512-Byte-Blocks)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No
   Ejectable:                No

   Whole:                    No
   Internal:                 Yes
   Solid State:              No

Let me know if there are any other commands I can run on the system that may give further information on how I can fix the MBR and to be able to boot from  Windows 7.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36960527
Oh, just re-read Roylong other questions.

I created the data partition using the graphical user interface of "Disk Utility.app" I've attached a pdf showing the partition screen for the HDD and highlighted the data partition I created using the app, by choosing partition layout to be 3 partitions.

 partition.pdf
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36983823
I still haven't been able to find a solution.

Basically, if no one can provide a recovery method then I only have the option of destroying my Bootcamp partition and recreating.

I'm still hoping for a solution before going for this option. I return home this Friday/Saturday, so will be looking to remove the partition and starting a new bootcamp this weekend.
0
 
LVL 15

Expert Comment

by:roylong
ID: 36984283
You killed it by using the disk utility, which no concept of windows partitions.  Bootcamp sets it up correctly, disk utility destroys the windows info from the disk.

The way I did this for triple boot was to allocate my mac partition and 'other' partition using bootcamp and then hive off part of the 'windows' partition for Linux - or for data in your case.

Make sure your mac partition is as big/small as you want it to be during the bootcamp setup process.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 36989860
Each time I ran Bootcamp Assistant it only gave two options either create the bootcamp partition or merge into one Mac partition.

If I understand from your comment you created the bootcamp partition using Bootcamp Assistant. Then once Windows was installed used Windows disk management utilitiy to hive off a portion of the bootcamp partition as your linux partition.

It is unfortunate that you didn't see my other message, as I had asked how best to create a third partition for my data. The advice then was that Disk Utility was okay to use.

I tried running Bootcamp Assistant and it now tells me that the the startup disk cannot be restored to a single partition or partitioned.

I guess I need to now remove the partitions with Disk Utility and start again?
0
 
LVL 15

Accepted Solution

by:
roylong earned 2000 total points
ID: 36991992
I apologise for any confusion.  The best option now would be to repartition from the macintosh to a single partition, as you say, and start again.  Also (as you say above) hive off from the Bootcamp Partition after this completes (using a Windows tool).

You can try to create your single partition with Disk Utility, if you get a problem then there are better ways to do this at the command line.  Please advise if you would like more in depth instructions on doing this.

Take a look at these links for information you may find useful::

https://help.ubuntu.com/community/MactelSupportTeam/AppleIntelInstallation

http://www.macgeekery.com/tips/cli/nondestructively_resizing_volumes

http://ideasarehere.net/2010/09/resizing-volumes-changing-partitions-mac-os-x-disk-utility-terminal/
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 37022706
Thanks for the information.

Had a brief look and will look more closely and start the process.

Will post if I need any further clarifications.

Thanks
0
 
LVL 1

Assisted Solution

by:sunspots2002
sunspots2002 earned 0 total points
ID: 37024792
A friend suggested trying MBRTool (http://www.diydatarecovery.nl/mbrtool.htm) as a way to recreate the missing entry. However, we weren't able to recreate the missing entry.

I have now removed the partition I created for data. The Bootcamp Utility then was able to recognise that I had a bootcamp partition and offered to create just the one Mac partition.

I decided not to do this and to see what would happen when I rebooted the system. Upon rebooting I choose the Windows 7 partition and was surprised to find that Windows 7 booted.

Rebooting into OSX and running vmWare Fusion I found that it too now recognised the partition and was able to create a virtual machine from it.

The only issue I have remaining is merging the data partition I created back into the OSX partition. I have tried extending the OSX partition with DiskUtility app and on clicking apply it goes through the process but doesn't make the change. The OSX partition is 249GB and after the merge it should be 299GB.

Any suggestion how I regain this lost partition and retain the Windows partition?
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 37126205
Hi, My question seems to have fallen off the radar. Anyone have any thoughts on how I can merge the data partition back into OSX partition?

See above for details.

Thanks
0
 
LVL 15

Expert Comment

by:roylong
ID: 37126665
Missed this in all the other emails - I thought you had got the answer to the original question.
Is there anything on the data partition?
Have you tried using the command line tools diskutil?
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 37168018
Thanks for replying.

No, I hadn't placed any data as yet on the data partition. I hadn't thought or thought that the GUI version does everything the command line version does. I'll have a look at the command line and search around to see if it can help.
0
 
LVL 1

Author Comment

by:sunspots2002
ID: 37205370
Hi Roylong
I had a look at the command line application and cannot see a command to use to merge the partition.

I have had further thoughts on your comment that you felt the question had been answered. I guess you can see it two ways. Firstly, I'm not completely back to square one, that is there is still the outstanding 50gigs not available. However, my Windows system is back up and running. So, from that point the assistance provided did get me to get the Windows running again.

So, I'll close this question and open another with the other issue I have. I hope you will be able to come to my new question and assist.
0
 
LVL 1

Author Closing Comment

by:sunspots2002
ID: 37230562
I marked the solution as A, as Roylong provided detailed help and assistance to my issue. However, it didn't directly resolve the issue. I would not have resolved the issue if had not been the different tips and suggestions made by Roylong.

For anyone coming to this question having the same issue as I did, I have marked my comment which actually did fix the problem of getting Bootcamp to recognise again the Windows partition.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
While there are many new features for iOS 11, these are the five that can improve your digital lifestyle.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Suggested Courses

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question