• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 328
  • Last Modified:

Coldfusion Database File Location

I am trying to create a new Data Source Name in Coldfusion MX7.
The database file is located unfortunately located on another computer and whenever I enter the UNC "\\MyAppServer\Database\ABC.MDB", I get an error.
I also tried a mapped drive like X drive pointing to \\MyAppServer\Database, but the result was the same.
Of course when I copied the database from \\MyAppServer\Database to a Local folder where CF resides, then no problem creating DSN name.
I like to know if I must have the data file on the local computer where CF MX7 resides in order to create a DSN.

Thank you.
0
sglee
Asked:
sglee
  • 6
  • 5
  • 5
  • +1
10 Solutions
 
RickEpnetCommented:
What are the NTFS and Shared Rights to where the database is. It will have to have Read and Write. Just as a test give the Share and the Folder Everyone with Full Access. See if it works. The you can back it off from there.
0
 
RickEpnetCommented:
Sorry forgot Are these Domain Member servers or are they just Workgroup servers?
0
 
ansudhindraCommented:
Are you sure that the network path is available from your machine with out giving any user name or password?
Better you login to the network machine "\\MyAppServer\" with the username and password saved from the machine in which you are trying to establish datasource.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
_agx_Commented:
> .. I get an error.

What's the error?

> located on another computer and whenever I enter the UNC

To clarify, that won't work unless the CF service is running under an account that has permissions to that share.  Normally it doesn't.  The CF service normally runs under the SYSTEM which has minimal resource permissions. See Running ColdFusion as a specific user
0
 
sgleeAuthor Commented:
To experts,
Sorry for the late reply. It has been hetic since I posted my question.

RickEpnet & ansudhindra:
--------------------------------------------
This folder as you see in the attached, I am currently logged in as domain administrator on the CF server and I can view/change/delete anything in the PO2000 folder that contains PO2000.MDB.
FYI, This CF server used to be part of old domain. Recently I disjoined it from old domain and joined it  to the new domain. The ACCESS database file "PO2000.MDB" is located on the new Domain Controller. The domain administrator has full access/control on the \\XXX\External\PO2000 folder.

agx_:, Here is the error message
----------------------------------------------
Connection verification failed for data source: PO2K
com.inzoom.adojni.ComException: Not a valid file name.
The root cause was that: com.inzoom.adojni.ComException: Not a valid file name. in Microsoft JET Database Engine code=0 Type=1

CF-Error-and-UNC-Path.doc
0
 
ansudhindraCommented:
just try creating a mapped drive in "My Computer" and access the access databse file as x:\path to file\file.mdb

you can map a network drive by right click on  "My Computer" and select "Map network Drive" in the menu.... and alsways do connect to network drive on startup.

BR-Sudhindra-www.clicksperday.com
0
 
sgleeAuthor Commented:
ansudhindra:
-------------------------------------------------
I just created driver letter W mapped to \\XXX\External.
I entered W:\PO2000\po2000.mdb into CF and received the following error. Please see attachment for screenshots.

Connection verification failed for data source: PO2K
com.inzoom.adojni.ComException: 'W:\PO2000\po2000.mdb' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.
The root cause was that: com.inzoom.adojni.ComException: 'W:\PO2000\po2000.mdb' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides. in Microsoft JET Database Engine code=0 Type=1

CF-Error-and-UNC-Path2.doc
0
 
ansudhindraCommented:
instead of "\\XXX\External\PO2000\po2000.mdb" try giving ip as "\\126.23.45.67\External\PO2000\po2000.mdb".

ip "126.23.45.67" is just for example here.. replace with the machine IP.
0
 
sgleeAuthor Commented:
ansudhindra:
-------------------------------
I tried \\192.168.1.9\External\PO2000\PO2000.MDB as seen in the attached, but I get the follwing error.

Connection verification failed for data source: PO2K
com.inzoom.adojni.ComException: Not a valid file name.
The root cause was that: com.inzoom.adojni.ComException: Not a valid file name. in Microsoft JET Database Engine code=0 Type=1


CF-Error-and-UNC-Path3.doc
0
 
_agx_Commented:
> I am currently logged in as domain administrator on the CF server

@sglee - Just to clarify, it's the CF service that must be logged in under the Administrator account (not you). ie Start menu > Settings > Control Panel > Services.   Is that what you're saying?

See here for instructions http://kb2.adobe.com/cps/172/tn_17279.html
0
 
ansudhindraCommented:
Usually services start using "Local account"..
try starting services as the account that access the remote share ..

I mean, go to "Start->Run->services.msc"
then in the services list select the coldfusion services, right click and go to properties and click on second tab "Log On" and provide the account details that can access the remote server..

and restart the services...
0
 
ansudhindraCommented:
0
 
_agx_Commented:
    > try starting services as the account that access the remote share ..

Like I said earlier - that's mandatory.  The CF service MUST be running under an account that has permission to the file.  There may be other issues, but nothing's going to work if CF doesn't even have permission to access the file.
0
 
sgleeAuthor Commented:
ansudhindra: _agx_:
------------------------
Since your suggestion about going to services.msc and change LOG ON information, I think I know where it went wrong.

Like I mentioned, this CF / W2003 App Server used to belong to old domain. We installed a new Domain, so I joined it to the new domain. While setting up a new domain (W2011SBS), I had to created a differnet administrive account callid "PSIADMIN" instead of traditional admin account name "ADMINISTRATOR" in W2003 server.
That said, I think CF was still using old local admin account called "administrator" which does not exist on new domain controller.

As you see in the attached, I changed user name and password on all 4 CF related services and restart, I could not even load CF Administrative screen to go to CF Admin Menu. So, I switched it back to "Log on as Local System Account".

Tonight should I try to create a local account called "PSIADMIN" and assign the same password and leave CF related services Login on properties as "Log on as Local System Account" and try to see if CF accesses the folder that has MDB?



CF-Error-and-UNC-Path4.doc
0
 
_agx_Commented:
Try one more test. Any change if you check the interact with desktop box?
    http://www.talkingtree.com/blog/index.cfm/2005/7/27/UNC4CFMX


btw: with your old setup, what account was CF logged in under? Administrator ..
0
 
sgleeAuthor Commented:
_agx_:
--------------------
yes administrator was the main admin account on CF server running W2003 Server.

Regarding "check the interact with desktop box" I am afraid to make any changes to these existing CF services anymore. We are running mission critial web-based applications off this CF server and I can't afford to make changes that would impact the operation of these existing systems.

So What I am going to try is to create a new local account in compmgmt.msc of CF server and log back in using that new account (which is identical to domain admin account username/pwd).
0
 
_agx_Commented:
Understood.  (Hopefully you have DEV or QA box you can test things on first?)

0
 
sgleeAuthor Commented:
Thank you for your assistance. As you suspected, I tlhink it is a permission issue. As I indicated, this computer running W2003 Server used to be a part of one domain, but now on another domain (W2008 Server). When I log in to this computer, it uses a different administrative login name and I believe that is where the confusion comes from.
  All the local database files are running fine.
  Since this is a production server, I can't afford to mess with it, so what I decided to do is to setup  COLDFUSION server on another server running Windows 2003 with the same adminitrative account username and password as in Windows 2008 Server domain.

Thank you all.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 6
  • 5
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now