• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 542
  • Last Modified:

Event ID 107 Folder Redicrection

Hi Folks,
I upgraded an old 2K3 AD to a 2K8 R2 AD over the weekend. A BDC took the place as the GC while I properly demoted the PDC, wiped out C: partition and reinstall 2K8 R2. Partition D with users profiles was intact.

I updated GPP and client side patches from microsoft, and indeed printers and drive mapping works properly. Folder redirection worked Sat, but today Monday morning, users were not able to see their desktops and my docs. Its like they are still looking for the old location. I had to go on the reg and manually change the string value Personal under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders and HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Which worked, but its a nightmare to do this for PC having more than one user logging in to them.

Any idea what might have gone wrong?

Why did it worked on Sat and today its not working?

Any easy way to patch this weird problem?

p.s. I also tried changing the default user account since someone mentioned something about it but that did not do the trick.

Any help would be greatly appreciated.
0
SpiderPig
Asked:
SpiderPig
  • 6
  • 3
  • 2
1 Solution
 
jodiddyCommented:
The demotion was successful with no errors?

When you say it was working SAT, how did you test?

Desktop and MyDocs locations are controlled by group policies on your network? Was this changed to the new way 2008 does it or did you use scripts?

Has the new 2008 DC taken on any roles?

Is the new 2008 DC the same name as the old server?

0
 
AcklesCommented:
Spiderpig,
I am sorry, but your timeline doesn't say anything, I mean what was before SAT or after how do you expect us to know????

Now, coming back to the story, you are mentioning that you updated GPP & CSE. However you never mentioned how did you do the transformation of GPO's for Folder Redirection.

Did you create new & before that did you remove the old?

We understand your nightmare, however please be clear in your description so we can resolve the issue in shortest possible time.

A
0
 
AcklesCommented:
Also please state your complete environment i.e. Client OS with SP.
 

As far as the event id you mentioned, here is the link:

http://www.eventid.net/display.asp?eventid=107&eventno=2577&source=Folder%20Redirection&phase=1

The most obvious problem looks like to be rights on the folder, which makes sense as per what you have said because you mentioned "Partition D with users profiles was intact" but I am sure ACL for the partition D are not same as they were in the old environment & when the profile loads it points to the location, but has no rights on it.

Please let me know what you think?
A
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
SpiderPigAuthor Commented:
Yes the new Windows 2008 R2 is fully functional as an AD, FS, and PS. It is a GC. I have created 3 new GPOs to map two network drives , install 7 printers, and do folder redirection for Desktop and My Doc. Printers and network drive works fine, it is folder redirect.

There was another script that did folder redirect jsut fine on the previous Win2K3 AD.

I tested it Sat by login using a regular user and admin and I noticed the desktop had the files that were redirected.

Today the desktop and my doc complained that the old server is not there. It was not even going to the new 2K8 R2 server.

Hope this makes more sense.
0
 
AcklesCommented:
I am sorry, but can you confirm that GP was already applied on Sat when you checked or is it that you only saw the documents?
0
 
jodiddyCommented:
hmm..

Good question Ackles!!  Sounds like the GPO hadn't updated on the machine for the test on Sat.

Try performing a gpupdate /force!  One easy test would be to create a new random mapped drive, then run the gpupdate /force command and see if it shows up.  If it does you know the workstation is pulling the GPO's from the correct server, then you can move onto the GPO you created being flawed or maybe it's just that the old settings need to be flushed out, in which case performing a gpupdate /force will do just that.

Why not just use the same script from the old system?

What is the domain functional level?  2003 or 2008?

0
 
AcklesCommented:
The point is Folder Redirection takes upto 3 login by design or you can put this policy at domain levevl & then Reboot the client:
Computer Configuration | Policies | Administrative Templates | System | Logon Always wait for the network at computer startup and logon policy

This way you will get it on first login.
Also check the rights on share as this is new Server
0
 
SpiderPigAuthor Commented:
i think that is what happened, I saw a left over form previous domain or something. Either way, something is weird with the server still, I think I need to remove the old DNS and AD. When i do gpresult I see the pc got the gpo from old server not new, not sure how to make it take it from new server. Here is why it is acting up weird, every 2-3 reboots the network drives will not show up and then after few mins they show up all of a sudden while the PC report event id 107 that the server was not able to copy files from old server to the new server (not sure why it wants to do that).

I solved the slow logins after disabling the delete all network printers before creating GPP printers.
0
 
AcklesCommented:
Check this out:
http://www.eventid.net/display.asp?eventid=107&eventno=2577&source=Folder%20Redirection&phase=1

Bottom line from the above mentioned post is:

"For example, if the previous user was set up to redirect My Documents to "\\server\share\%username%", and the settings got saved in the Default User folder, and the current user does not have access to "\\server\share\$username%", this error will pop up and no folder redirection will occur. The solution is to delete any files from the "C:\Documents and Settings\Default User\Local Settings\Application Data\Microsoft\Windows\File Deployment" folder. "

A
0
 
AcklesCommented:
Spider,
I think your problem is based on few things, you can see what all can be neglected. But, before that let me try to explain what I think has happened:

1) The old server had Share, Printer & Folder Redirection
2) You made the new DC
3) You changed the printer & share on the new server
4) Folder Redirection??? How did you implement?

But, I think if you follow the above post we can at least rule that out. I had this posted earlier also, but never saw you confirming it.

Please have a look & try the resolution, if it doesn't work then we dig deeper.

TX,
A
0
 
SpiderPigAuthor Commented:
Looks like it stopped happening. Thanks a bunch for your help.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now