Avatar of howejustin

asked on 

Scheduled Task not launching .bat or .cmd file (Win2K)

Hi all,

I have some Windows 2000 servers that I would like to run a .bat or .cmd file with (the .cmd file is basically the robotask version of the .bat file, since .bat hasn't been working) that xcopy's an SQL dump file to an offsite NAS box. If I run the .bat file or .cmd file manually, it works just fine. If I try to run it from the scheduled task, it runs with an empty status and 0x0 in the result field. The .bat and .cmd files were created using the Administrator account, as was the scheduled task (which has the password set as well). The .bat and .cmd files have full permissions set for everyone and Administrator to have full control, and Administrator is the owner.

-All files and tasks created as Administrator
-All permissions are set up correctly
-Tried using full UNC paths in the task, ie: \\servername\c$\etc...
-Tried putting the .bat and .cmd files in the system32 directory
-All tests have been with small log files that are <3MB in size, not the full 15GB database dumps.

What else can I try so that I may get this task to actually run, as well as put the files up on the NAS box? (The NAS box has proper permissions set, too. As specified before, manually launching the batch files works just fine).

FYI: I'm running these tasks as administrator because it's no problem that they run with full priority. It's starting at 11pm and will finish by 6am, so it's not during working hours.
Windows 2000IT Administration

Avatar of undefined
Last Comment

8/22/2022 - Mon