• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 511
  • Last Modified:

which JSTL to download ?

I want to use  JSTL  in my JSP.  Which JSTL  version you recommend ?

Application Environment  has
----------------------------------------
Server  JBOSS 5.0 or above

JAVA:   JDK 1.5

Struts 1.3


Which JSTL version download  is compatible with my  environment ?

Could you please tell..
(i)post me right JSTL version  download link.

(ii) what  taglib uri to import at the top of JSP.
0
cofactor
Asked:
cofactor
  • 4
  • 2
1 Solution
 
for_yanCommented:


I think you can look here:
If you download this jar file:
http://download.java.net/maven/glassfish/org/glassfish/web/jstl-impl/1.2/jstl-impl-1.2.jar

copy this .jar to .zip extension and open it with winzip, you'll indeed see .tld files there.
I'd say there are more than eight of them
0
 
for_yanCommented:
0
 
for_yanCommented:
And I think this is taglib:

<%@ taglib uri='http://java.sun.com/jsp/jstl/core' prefix='c'%>

And these are probably the same links more directly:

http://download.java.net/maven/glassfish/javax/servlet/jsp/jstl/jstl-api/1.2/jstl-api-1.2.jar

http://download.java.net/maven/glassfish/org/glassfish/web/jstl-impl/1.2/jstl-impl-1.2.jar

theye do not come from JBoss, but I think they should be standard
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
cofactorAuthor Commented:
I see you have JSTL 1.2 download.   Will it run on JBOSS 5 ?  

I'm worried about this  because JSTL version and JSP version needs to be compatible....is not it ?
0
 
for_yanCommented:
I think it is worth trying JSTL 1.2.
At least I was trying to find something later at some point, but I think I could not - all links eventually point to these ones
(look at the links in the above posting - they end up with these 1.2)
0
 
cofactorAuthor Commented:
This worked.

I'm not sure how did you arrive at this ?  they are compatible.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now