• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2705
  • Last Modified:

SBS 2011 Cannot Send email to external domains

I just set up a new SBS 2011 server and am having trouble getting external email to send. I have found that the messages are stuck in the mail queue with a status of : "Retry"
The Last Error is the same for all which is: "451 4.4.0 primary target ip address responded with 421 4.2.1 unable to connect"
My ISP blocks port 25 so I changed the Send Connector port from 25 to 2525
I also added DNS forwarders of: 8.8.8.8, and 8.8.4.4 (Google Public DNS)

Please help me resolve this issue.
Thanks!
0
jmolhava
Asked:
jmolhava
1 Solution
 
stanley_starsCommented:
Verify that the settings of your Default Internet SMTP Send Connector is correct in the Organization Configuration --> Hub Transport and is enabled.
0
 
Cliff GaliherCommented:
You cannot arbitrarily change the port of the send connector. The destination servers don't know they should be LISTENING on port 2525, herefore connections are failing. ISPs block port 25 to prevent rogue dynamic IP clients from being part of spam botnets. If bypassing that was as easy as using a different port, that wouldn't be very effective.

You have two choices:

1) get a business class service from your ISP. This usually includes a static IP and unblocked port 25.

2) as long as running a mail server is not against your current ISP service terms of use, you can use a smarthost to relay mail for you. There is a wizard in the SBS console to configure a smarthost and it will use an alternate port (which you get from your smarthost provider) to avoid the port 25 block.

HTTH,

-Cliff
0
 
jmolhavaAuthor Commented:
@stanley - There is only one Send Connector which was setup by the wizard during install.
The FQDN is correct
The address space is SMTP with "*" for domain
Network is set to use (DNS) MX records to route mail. (no other options selected here)
Server tab is correct

0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
SuperTacoCommented:
is the exchange 2003 server (or SBS 2003) still up?  if so, try using the Exchange 2003 machine as a smart host on the 2010 send connector.  
0
 
jmolhavaAuthor Commented:
@cliff - That makes sense so I will have to go with a static IP option from our ISP. We are on a business line of service, but the static IP is an optional feature. I had changed the port because of another post elsewhere that talked about making that change. Thanks for clearing that up for me.
I will be making the change tomorrow and will close this issue out assuming that it resolves things.

@SuperTaco - The previous server was not an SBS server. Previously, email has been hosted through another company.
0
 
libran2011Commented:
Moreover to get the default settings on Connectors you can run Fix My network wizard which will configure the send connectors to the default.

Thanks
0
 
jmolhavaAuthor Commented:
Thanks for clarifying for me what was required. I did get a static IP with port 25 unblocked and now all is working well.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now