Twin drives confuse Windows 7

Posted on 2011-10-10
Last Modified: 2012-05-12
I'm trying to add two new hard drives to my Dell XPS Studio 9100, but Windows 7 will only recognize one of them at a time.  The two new drives, as well as the original drive, are SATA 1TB Seagate Barracudas with identical specs.  The BIOS recognizes all three drives and I do not have RAID enabled.  However, Disk Management in Windows 7 only sees one of the drives, and only one of the drives is shown in Device Manager as well.

My original drive running the OS is in SATA port 1 and the two new drives are in SATA ports 2 and 3; SATA port 0 has a DVD drive connected to it.  To debug the problem, I turned off the computer and physically disconnected the drive on port 3 then started the computer.  I found the drive in port 2 in Disk Management and created a partition for the whole drive and set it as D after naming the volume BackupXPS9100.  I could view and interact with the new disk in Explorer, and I created a file named This is disk 2.txt on it.  Then I turned off the computer, physically disconnected the drive on port 2, reconnected the drive on port 3 and booted.  Now the D drive was still accessible even though it was a different drive!  Even the volume name was the same even though I had never named a volume on this disk.  I created a file named This is disk 3.txt on this hard drive and then shut down the computer.  I then disconnected 3, reconnected 2 and booted.  Now drive D still exists and it shows the file This is disk 2.txt.

So, it seems like Windows can't tell the difference between the two drives.  They are interchangeable when I connect one at a time, even though they are on different SATA ports.  The problem is that the second one is not accessible when they are both connected.  How can I fix this?
Question by:bjp1662
    LVL 91

    Expert Comment

    post a screenshot of device manager plse
    LVL 91

    Expert Comment

    and one of device manager, with disk drives showing
    LVL 30

    Expert Comment

    Connect the operating sytem drive to sata port 0
     Connect the DVD drive to sata port 1.
     Connect the reset drives to 2 and 3

    Reboot computer and check.

    LVL 10

    Expert Comment

    The only OS listed for your particular computer is WINDOWS 7 x64 (64 Bit)

    Perhaps your problem stems from the need for the following Firmware update.  See the following link for installation instructions not posted here.

    The following picture was acquired from the Dell Downloads & Drivers for your Dell XPS Studio 9100

     Dell XPS Studio 9100 Seagate HDD Firmware
    Note that Dell recommends this update and that the update involves improvement in Intel system detection.

    Fixes and Enhancements
    - Improve the boot up detection.
    - Improve the Intel system detection.

    All Drivers & Downloads for Studio XPS Desktop 9100

    Note that Dell support for this computer only lists the WINDOWS 7 x64 Operating System

    Author Comment

    Nobus, I'll assume you mean device manager and disk management.  Picture below.

    ded9, seriously?  Why would changing the order of SATA 0 & 1 affect 2 & 3, and why should I have to change the factory configuration of my OS drive and DVD drive?

    Jim-R, I thought for sure that was going to be the solution, but apparently the *524 firmware doesn't apply to the *528 drives I have (picture below).

    Just so there's no confusion, I've also attached pictures of how my drives are connected.  The blue SATA cable goes to my DVD drive (not pictured).

    LVL 10

    Expert Comment

    Maybe I had the right "idea" but got the wrong "firmware" (because it was at Dell's site)

    I notice in your screen shot of the Firmware, One drive has CC49 firmware and the others have CC3E

    There is a New firmware version: CC49

    Its the two drives that are not working correctly (at least at the same time) and they are the same model number as the drive using the CC49 Firmware.  I don't know if this is relevant to how "version numbers" are set with Seagate drive firmwares, but CC49 is a "higher" number than CC3E in "computer numbering notation"

    Why not try the link I posted and have a look and see if your drives are the 7200.12 type.  There is a link to the CC49 firmware update download there and that model number shown on the screenshot is listed.  There is nothing when searching "CC3E" on the Seagate site, but if you search "CC49" it will find this firmware.

    Barracuda 7200.12 Firmware Update [213891]

    Please verify your drive model number, serial number, and firmware revision using the Drive Detect software.

    This article applies to the following models.



    Author Comment

    Jim-R, you were right about the firmware upgrade.  Here's a bit more background about the situation:  The primary drive is a replacement I received from Dell a couple weeks ago because the one that came with the computer a year ago failed.  This explains why the primary drive had CC49 (the latest) firmware.  The other two drives were purchased at Frys in Burbank, CA a couple weeks ago and did have old (CC3E) firmware.  Apparently Frys does not necessarily carry the latest equipment.

    The program at the link you provided resulted in a successful upgrade of the firmware on the two new drives; I have a picture of the success screen but I don't think it would be useful to attach.  After performing the firmware upgrade, I booted up with SeaTools DOS (on a boot CD) and took the picture below; it shows that all three drives are recognized and all now have CC49 firmware.  However, SeaTools Windows doesn't see either new drive (!), Seagate's Drive Detect can't read the drive name, serial number, or firmware revision, and the drive situation in Windows remains exactly as before.

    Any more ideas?  Thanks for the guidance so far!
    LVL 91

    Expert Comment

    i can only think of a corrupted bios - do you have the latest?
    or a bad motherboard
    do you have another sata drive around to test with?  prefereably another disk size ?

    Author Comment

    I have the latest (A02) BIOS relative to the files available from Dell.  When I run the BIOS update from Dell's website, it tells me I have the latest BIOS already.  I have also downloaded and installed Intel Storage Matrix Manager version 9.6.  Interestingly, Intel Rapid Storage (running in Windows) shows all three drives, their serial numbers, and their firmware versions.  Yet the drive situation in Windows remains exactly the same (screenshot below).

    nobus, you mean another SATA hard drive in addition to the three I'm already testing with?  No, sorry.  What test would you have me do that I can't do with the three I have already?  I've already shown that each physical SATA port works, each physical hard drive works, Windows can mount each drive, and Windows can access files from each drive.  The only problem is that it doesn't recognize both new drives at the same time.
    LVL 10

    Accepted Solution

    Well, at least you know it's NOT because of outdated firmware on the new drives.

    I also noticed in your screen shots, you have the drives in AHCI mode.

    Could you try running the drives in IDE or Compatible mode?  Perhaps windows needs to first "see" the drives the non AHCI mode and then install AHCI drivers afterward.  Windows setup has been known to not detect drives initially set in BIOS as AHCI and install fails.

    As goofy as ded9's suggestion may sound to you, some motherboards are picky about which port the OS drive is on when multiple HDD's are installed.  They like the OS drive to be on port ZERO.  As drive letters are assigned, usually the hard drive is 'C", followed by DVD/CD drive is "D" and then others as they follow.

    The only other suggestion I can think of at the moment, (which may not be possible on DELL OEM computers) is a "Repair" or "Upgraded" install (started from within Windows) using a Win 7 DVD (which your DELL may not have been supplied with)  A Repair install doesn't change settings or installed programs, it just redoes the OS.


    Assisted Solution

    Ok, solved.  Short answer: the motherboard was treating the 2 new disks as a RAID array.  Long explanation: I went through many cycles of shutting down the computer, rearranging the SATA cables, booting back up, and noting the effects.  Rearranging the cables didn't have any effect, but I noticed that the second drive now contained This is disk 2.txt rather than This is disk 3.txt.  That looked an awful lot like RAID behavior even though I repeatedly verified that RAID was turned off in BIOS (in favor of AHCI).  I looked all over the BIOS settings for a way to put the drives in IDE or compatible mode, but the only two options that seemed remotely like something I wanted was the S.M.A.R.T. flag and the AHCI/RAID toggle.  When I switched the toggle away from AHCI to RAID and booted, I was able to open the RAID configuration on boot up and sure enough, the two new disks were paired as RAID1.  I removed RAID from all disks, rebooted, changed RAID back to AHCI in the BIOS, and then booted Windows normally.  Now I could see both disks in disk management and I only had to change the uniqueid on the second disk to make it accessible like normal.  After changing the uniqueid, I had to reboot; rescanning the disks in Disk Management was not sufficient.  But, now everything seems to be working properly.

    Jim, thanks a ton for all your guidance -- I was about ready to give up and settle for two disks before your first comment :)

    Author Closing Comment

    Jim's guidance led to the RAID discovery
    LVL 10

    Expert Comment

    It would seem that Dell's site is somewhat less than up-to-date.

    What are the current bios for XPS studio 9100?

    A Dell forum user posts:

    Update, it appears the bios is the most updated, it's just Dells site that hasn't been updated to reflect it. Really Dell, A02 was from over a year ago. You can't even keep your site up to date? That's amazing! :(

    when inquiring why his Dell XPS Studio 9100 has BIOS version A04 and the latest at Dell is A02

    Also, similar to your problem another forum user posts the following topic:

    Installing Serial ATA drive into XPS Studio 9100

    Reading the entire thread has left me feeling something is really really wrong with either Dell's XPS Studio 9100 BIOS or the Win 7 x64 OS.  Since I have FIVE hard drives and a DVD/CDRW drive (ALL SATA) and have had no such issue, and others are having problems with HDD detection both internal and external, I'm leaning towards the Dell XPS 9100 BIOS choice in the matter.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    First some basics on Windows 7 Backup.  It has 2 components one is a file based backup which is stored in .zip files each zip is split at around 200 Megabytes and there is the Image Backup which is as the name implies a total image of the partition …
    In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
    In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
    This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now