[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1084
  • Last Modified:

Setting up PPTPD on Centos 6

I'm trying to setup a VPN connection in the office but I'm having some issues.

Firstly, some history, we don't manage the network in our office, but have a server connected to the network which has an external IP address forwarding to it, and VPN ports are open.

The server is running Centos 6 and we've installed Samba so we have a network drive. I'd like to be able to VPN into the server, connect to it and get access to the Samba share.

I've followed a number of tutorials and have installed pptpd, changed the pptpd.conf file, changed the options.pptpd.conf file and the chaps-secrets file.

On the local network, the server has the IP address of 192.168.24.132

I've attached the pptpd.conf file.

The firewall on the server is completely turned off.

When I try to connect to the VPN from my mac, it says I've been disconnected from the server. To connect to the VPN I'm providing the IP address of the server, my username and password, and selecting the connection type as ppp.

Because I don't get any specific errors it's difficult for me to figure out what the problem is.

Can anyone help?
# TAG: logwtmp
#       Use wtmp(5) to record client connections and disconnections.
#
logwtmp

# TAG: bcrelay <if>
#       Turns on broadcast relay to clients from interface <if>
#
#bcrelay eth1

# TAG: delegate
#       Delegates the allocation of client IP addresses to pppd.
#
#       Without this option, which is the default, pptpd manages the list of
#       IP addresses for clients and passes the next free address to pppd.
#       With this option, pptpd does not pass an address, and so pppd may use
#       radius or chap-secrets to allocate an address.
#
#delegate

# TAG: connections
#       Limits the number of client connections that may be accepted.
#
#       If pptpd is allocating IP addresses (e.g. delegate is not
#       used) then the number of connections is also limited by the
#       remoteip option.  The default is 100.
#connections 100

# TAG: localip
# TAG: remoteip
#       Specifies the local and remote IP address ranges.
#
#       These options are ignored if delegate option is set.
#
#       Any addresses work as long as the local machine takes care of the
#       routing.  But if you want to use MS-Windows networking, you should
#       use IP addresses out of the LAN address space and use the proxyarp
#       option in the pppd options file, or run bcrelay.
#
#       You can specify single IP addresses seperated by commas or you can
#       specify ranges, or both. For example:
#
#               192.168.0.234,192.168.0.245-249,192.168.0.254
#
#       IMPORTANT RESTRICTIONS:
#
#       1. No spaces are permitted between commas or within addresses.
#
#       2. If you give more IP addresses than the value of connections,
#          it will start at the beginning of the list and go until it
#          gets connections IPs.  Others will be ignored.
#
#       3. No shortcuts in ranges! ie. 234-8 does not mean 234 to 238,
#          you must type 234-238 if you mean this.
#
#       4. If you give a single localIP, that's ok - all local IPs will
#          be set to the given one. You MUST still give at least one remote
#          IP for each simultaneous client.
#
# (Recommended)
localip 192.168.24.132
remoteip 192.168.24.220-230

Open in new window

0
SheppardDigital
Asked:
SheppardDigital
  • 2
1 Solution
 
SheppardDigitalAuthor Commented:
I've managed to fix this myself.

I checked the log files for the systems and found an error. To fix, I edited the pptpd.conf file and disabled logwtmp
0
 
SheppardDigitalAuthor Commented:
Resolved this issue myself
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now