[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Error while trying to install Exchange 2007 SP3

Posted on 2011-10-11
10
Medium Priority
?
300 Views
Last Modified: 2012-05-12
Hi:

This message pops up when I try to install Exchange 2007 SP3:

"Installation program generated an error when performing action "Install". You can't resume installation if you run the action "BuildtoBuildUpgrade" (My translation may be imperfect)

I just run the SP3 setup program.

What's giong on here?

Thanks.
0
Comment
Question by:ScreenFox
  • 5
  • 3
  • 2
10 Comments
 
LVL 6

Accepted Solution

by:
sumit_arora earned 800 total points
ID: 36949009
you must be getting the events in the event viewer. Please paste those events here  
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 1200 total points
ID: 36949056
open regedit on  your exchange server and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\MailboxRole (and other roles)

you have a key called watermark ?


what is the

ConfiguredVersion" and  "UnpackedVersion"
0
 
LVL 6

Assisted Solution

by:sumit_arora
sumit_arora earned 800 total points
ID: 36949078
http://support.microsoft.com/kb/947281

try to install exchange sp3 as per the article
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:ScreenFox
ID: 36949119
In MailboxRole I have:

Action: Install
UnpackedVersion: 8.1.240.6
Watermark: 1119612730 (decimal)
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 1200 total points
ID: 36949393
Do you have watermark in another role? Rename the watermark key to something else and try again
0
 

Author Comment

by:ScreenFox
ID: 36949821
I don't have Watermark in any other role. Renaming that kay does not solve the problem.
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 1200 total points
ID: 36949963
Make sure waterpak does not exist and add a key called

ConfiguredVersion reg_sz 8.1.240.6
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36954776
Hey which one solved your issue ?
0
 

Author Comment

by:ScreenFox
ID: 36954832
Sorry, forgot to tell before.

I made the changes you said to the registry keys, and used the command "setup.com /m:install /r:mb" in the SP3 directory. Then it worked.

The comment where this command was posted was deleted.

Thank you all for your comments. They have been very helpful.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36954835
thanks for the update
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question