[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Citrix Receiver issue??

Posted on 2011-10-11
14
Medium Priority
?
1,958 Views
Last Modified: 2012-05-12
Setup-
PS 4
WI 5.4
CAG 4.5.6 standard

If I set Citrix Receiver like this-

I can get IPAD to work using Citrix receiver in the following setup-

•Configure address  https://mycompany.co.uk
•Set it to XenApp Services - in Citrix receiver

Works fine if I am on the same network of the Citrix environment i.e. (work)
If i try from outside i.e. from home, I get to see all published  apps but when I click on a app, it just say’s please wait…and then back to apps list. (The app does not launch). If I then VPN into my work and try again it works!!!

If I set Citrix Receiver like this-

•Configure address https://mycompnay.co.uk
•Set it to Access Gateway (Standard) - in Citrix receiver

It does not work whether I’m on the (work) network or outside (home). I get an error
“Gateway authentication failed. Please check your credentials, address, gateway settings, and network connection.”

Any ideas, as I have tried everything I can possibly think of, from what I can tell its struggling from the actual CAG…
Thanks
0
Comment
Question by:badabing1
  • 8
  • 6
14 Comments
 
LVL 26

Expert Comment

by:Tony J
ID: 36954106
From the sounds of it, I wouldn't have thought it was authentication as you can log in and see your apps (although I guess it could be failing to pass the credentials through to the XenApp servers).

There are some decent step-by-step instructions on the eDocs site, just a bit buried.

http://support.citrix.com/proddocs/topic/receiver-ios-4-2/iphone-receiver-admin-config-agse.html

It's also worth noting that PS4.0 isn't actually in the list of supported idevice receiver list:

http://support.citrix.com/article/CTX120601

That KB article also leads onto more CAG 4.5 specific step-by-step instructions with screen shots for the settings, which might be more useful to you:

http://support.citrix.com/article/CTX121093

0
 

Author Comment

by:badabing1
ID: 36954750
Hi,

i already followed these doc's, - not sure what im missing, only thing i can think of is the PS version, but then how come it works ineternally?
0
 
LVL 26

Expert Comment

by:Tony J
ID: 36954777
The only thing I could think of is the way the CAG is passing through authentication from an external address.

But you're right - I wouldn't expect it to work internally either.

Can you browse to the external website and connect? I realise it's still using the receiver, but it's a slightly different mechanism.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:badabing1
ID: 36954952
Yes i can and it does work using the browser setting in citrix receiver!

0
 
LVL 26

Expert Comment

by:Tony J
ID: 36954979
The only thing I can think is a breakdown in how the receiver is passing authentication on but that kind of breaks down as it works internally.

Sorry mate, but I'm out of ideas on that one.

Does anything get logged in the event logs on the WI or PS servers just after the failure?
0
 

Author Comment

by:badabing1
ID: 36955262
ill check logs and see if i can anything- you are referring to windows event logs?
0
 
LVL 26

Expert Comment

by:Tony J
ID: 36955703
Sorry - yes the windows event logs.
0
 

Author Comment

by:badabing1
ID: 36967306
nothing unsual im afraid.
0
 
LVL 26

Expert Comment

by:Tony J
ID: 36967388
When you connect internally, is it also via the CAG?

The only thing I can imagine is something is being stripped out or not recognised between the CAG and the PS servers, but unfortunately because they're v4, Citrix would just say to upgrade :-(
0
 

Author Comment

by:badabing1
ID: 36968167
yes - but it will not work if the setting is set to access gateway in citrix receiver- but if it is set to xenapps services which still goes via CAG it works.

if i using WI, which goes via CAG it works - so seems like the setting for CAG in citrix receiver dont work everything else work!  
Thanks
0
 

Author Comment

by:badabing1
ID: 37005276
in the end i had to set secure access of xenapp services to "gateway direct" this worked!

Thanks
0
 

Author Comment

by:badabing1
ID: 37006488
I've requested that this question be closed as follows:

Accepted answer: 100 points for Tony1044's comment http:/Q_27390793.html#36954106
Assisted answer: 0 points for badabing1's comment http:/Q_27390793.html#37005276

for the following reason:

i have awarded some points for helping out. thanks
0
 
LVL 26

Accepted Solution

by:
Tony J earned 1500 total points
ID: 37006489
Sorry, but had you followed the step-by-step instructions in my very first response, you would have seen the following:

e. Change the Access Method to Gateway Direct, as shown in the following screenshot:

And the associated screenshot.

I therefore feel that had you followed the instructions in said link, it would've answered your question and as such I provided the resolution.
0
 

Author Closing Comment

by:badabing1
ID: 37008957
yes, you are right- my apology.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
#Citrix #POC #XenDesktop #vCenter #VMware #ESX
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question