Windows Sharepoint Services 2 to 3 WSS upgrade fails with: ". is an invalid or loopback address"

Posted on 2011-10-11
Last Modified: 2012-05-12

We are trying to upgrade a WSS 2.0 to a 3.0 environment (mail goal: upgrade to Foundation).

Server = WIndows Server 2003 32 BIT STD
Sharepoint = WSS = 2.0

Upgrade keeps failing when upgrading the content databse (step 2 of the upgrade process). It always fails with this error:
". is an invalid or loopback address"

What I've tried allready:
Change the configuration and content databse via SP to use "SHAREPOINT" as host (servername = SHAREPOINT)
Runned prescan /fixlocalhost
Checked DNS settings (works fine, ping SHAREPOINT does resolve to the fixed IP of the server)
Checked if the MSSQL witch is running on SHAREPOINT, allows connections on default port 1433
Checked i in IIS the fixed IP is linked to the SharePoint site instead of All unassigned
Checked the registry value (MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\6.0\Secure\ConfigDB and the value of teh string dsn (contains the correct name = sharepoint / db / userlogin + userpass)

I'm really stuck for allmost 3 days now... Any tips hints would be greatly appreciated !!!
Question by:willux
    LVL 1

    Expert Comment

    All I can suggest is working through this update carefully, step-by step. Here is a very good upgrade document:


    Author Comment

    Hi rattlerant, thank you for your feedback, but this error occurs between the final step of fase 3a and the beginning of step 3b, so when the actually DB upgrading has begun...

    I've based my upgrade on the steps in the manual you mentionned... The real I need to soleve out is where Sharepoint gets the . (dot) from while performing an upgrade on the configuration DB:
    ". is an invalid or loopback address", there should be an IP or a servername...
    LVL 13

    Expert Comment

    by:George K.
    Try to update database TCP port so that default is 1433.
    LVL 13

    Expert Comment

    by:George K.
    Also check with AD permissions
    Grant Authencticated users with read permission
    Also do not forget to issue IISRESET after this.

    Author Comment

    Hi Georgekl,

    First of all, thank you for your post !!!

    SQL is running at default port 1433.

    The part of the AD permissions I didn't get, how can i check that ?

    Best regards,



    Accepted Solution

    Problem is solved:
    Open de SQL Manager
    Go to the SharePoint config database
    Find the Servers tablle
    You'll find 1 or more values with the servername that shows up in the error, in my case "." (dot)
    Change it to the IP address or name of teh SQL server that hosts your SharePoint config database
    Relaunch the upgrade and enjoy how it works :)


    Author Closing Comment

    It works...

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    This collection of functions covers all the normal rounding methods of just about any numeric value.
    These days socially coordinated efforts have turned into a critical requirement for enterprises.
    The viewer will learn how to simulate a series of sales calls dependent on a single skill level and learn how to simulate a series of sales calls dependent on two skill levels. Simulating Independent Sales Calls: Enter .75 into cell C2 – “skill leve…
    The viewer will learn how to count occurrences of each item in an array.

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now