Suddenly got lots of email addresses in Outlook 'To' field

We have just installed exchange 2010 and suddenly it appears that all our users have got every email address the company has sent to as an option in their 'To' field. Is there a configuration setting I need to tweak in Outlook or Exchange?
suromaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

madhatter5501Commented:
when you say the to: field are you referring to the GAL or the .nk2 cache?
0
suromaAuthor Commented:
Sorry but I am not quite sure what you mean. If I start typing the name in the 'To' field textbox in a new email I get a long list. If I click the 'To' button I just get our address books which are fine.
0
madhatter5501Commented:
the .nk2 file is a cache of addresses you have sent mail to, here is a link that will walk you through resetting that to a clean slate

http://www.daycomsolutions.com/Support/ResetNameListInOutlook.html
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

suromaAuthor Commented:
Thanks for putting me on the right path with terminology but it seems that Outlook 2010 doesn't use .nk2 files but uses .dat in C:\Users\{username}\AppData\Local\Microsoft\Outlook\RoamCache\Stream_Autocomplete_y_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.dat (y = file index, x = random 16-byte key in hex form).
I renamed the current ones but it just recreated them. I then found that they are now kept on the exchange server (Recipient AutoComplete lists are now stored on the Exchange Server. A user’s recipient AutoComplete list is now available to any computer on which Outlook 2010 runs that is connected to the same Exchange account. Names can be easily removed from the list by using the new inline Delete function. - http://technet.microsoft.com/en-us/library/cc179110.aspx) but I can't find a way of managing them yet.
0
linrafCommented:
If you want to clear the list completely:
File
Options
Mail
Send Messages section
Empty autocomplete.

You can also turn off that function there.

If you are looking to bulk remove entries from it try nk2view from nirsoft.net
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
suromaAuthor Commented:
Thanks for the info. I have resolved the problem now to the best of abilities as it seems although stored on Exchange it can not be managed centrally.
http://aspoc.net/archives/2010/05/04/how-to-clear-the-autocomplete-list-in-outlook-2010/
0
suromaAuthor Commented:
Thank you madhatter5501 for pointing me in the right direction and linraf for the 2010 solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.