Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 791
  • Last Modified:

IIS 7 issue

New to IIS running on Windows Server 2008 R2. Server running SQL 2008. Currently WSUS services and Scriptlogic HelpDesk Authority without issues. A vendor is attempting to install a budgeting application and when trying to connect via website receives the error message attached. Indicates it is not a problem with their software and is an IIS configuration issue. Have found posts indicating to comment out lines in applicationhost.config but do not know the proper method for doing that to test. Need a resolution ASAP to continue moving forward with this server and database installs
IIS-error.png
0
kingsville
Asked:
kingsville
  • 8
  • 6
1 Solution
 
rattlerantCommented:
Try disabling Dynamic compression in IIS7:

To Use the UI

    Open IIS Manager and navigate to the level you want to manage (the budgeting application's website). In Features View, double-click Compression. On the Compression page, UNselect the box next to Enable dynamic content compression.Click Apply in the Actions pane. Do an IISreset from command Prompt.

You may also have to elevate the privileges of the Application Pool user to provide it permissions to modify the .config files. To do so, create a user account (local or domain)  specifically for this application, give it appropriate permissions by adding it to the elevated local or AD group. and change the application pool to run as this elevated user. Do an IISreset from command Prompt.

of course, back-up your *.config files before making any changes.

- Rattlerant
0
 
kingsvilleAuthor Commented:
I have already tried your first suggestion and it did not work for me.

They configured NetworkService account - should I change that. again - all very new to me
0
 
kingsvilleAuthor Commented:
also - I read an article indicating to Comment out the section of applicationhost.config where it says:

<httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
            <scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" />
            <scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />
         

How do I comment out something in the config file to even test if it may work?
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Brad HoweCommented:
Check your default document setup and try browsing to an actual page .

1. Try to browse to an actual page.
    http://localhost/teambudget_prod/page.asp|aspx|htm|html.

2. Configure the Default Document for the site.
http://technet.microsoft.com/en-us/library/cc753615(WS.10).aspx 

3. Verify your Application Pool is setup properly for the correct framework. There is CLASSIC and there is INTEGRATED. They both make a difference and behave differently.

As well, do not try to mess with the applicationhost.config. That is the main IIS configuration file and is usual locked.

Cheers,
Hades666
0
 
kingsvilleAuthor Commented:
1 - gives me the screen shot I sent in the original post accept now the Notificaiton and HAndler are different (see attached)
2 - already configured to default.htm
3 - vendor setup the framework and installed .NET 4 specifically for them
IIS-error-default-htm.png
0
 
Brad HoweCommented:
Ok,

1. Does default.htm exist
2. Can you please enable Failed request Tracing.

Essentially, you are missing a module the site requires. To help, you can install Failed request tracing to help determine the module that is causing the failure in the ApplicationHost.config, reproduce the problem and then fix the reference.

Install FRT
 ASP.NET (under World Wide Web Services - Application Development Features - ASP.NET)
 Tracing (under World Wide Web Services - Health and Diagnostics - Tracing)

Next enable it and set the log file.
You can follow the below help link to get you setup.
http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-7/

Particularily the section - Enable Failed-Request Tracing

Once reproduced, please attach the log file for review.

Cheers,
Hades666
0
 
kingsvilleAuthor Commented:
Attached are the log files created
fr000001.xml
freb.xsl
expanded-log-file.png
0
 
Brad HoweCommented:
Ok, Better error.

So dynamic and static compression modules are missing.

Fix is to install them.

START | SERVER MANAGER
Select ROLES
Select Web Server (IIS)
Scroll down to Add ROLE SERVICES

ADD [x]
   Common HTTP Features | Static Content
   Performance | Static Content Compression
   Performance | Dynamic Content Compression

Next, Install, Finish.

Try again, :)
Hades666
0
 
kingsvilleAuthor Commented:
All of the above are already installed and currently greyed out as possible selections with check mark next to them all.

Are these features 64 bit and possibly the app in question is calling for a 32 bit version. is there a way to tell the 32 bit apps not to use this feature. I'm grasping at straws. Just throwing out ideas
0
 
Brad HoweCommented:
Ok. I just re-read your original post.

can you please execute the following for me and post the results?

CMD> %windir%\system32\inetsrv\appcmd.exe list config -section:system.webServer/httpCompression

Thanks
Hades666
0
 
Brad HoweCommented:
Also provide the output of the following.

%windir%\system32\inetsrv\appcmd.exe list appPool "Your AppPool name" /text:*

you can get the "Your AppPool name" by executing the following.

%windir%\system32\inetsrv\appcmd.exe list apps

Cheers,
Hades666

0
 
Brad HoweCommented:
Ok,

The issue is because the appPool is running in 32Bit mode (enable32BitapponWin64='True') and this DLL is a 64Bit DLL for WSUS.  

If you chose to craete a NEW website with a separate Header binding - My personal suggestion, this would not occur.

This is the result of having a DEFAULT WEB SITE with WSUS and adding applications into it.

Please execute the following and try the site again.

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /+[name='xpress',doStaticCompression='false',dll='%windir%\system32\inetsrv\suscomp.dll']

cheers,
Hades666
0
 
kingsvilleAuthor Commented:
results of the last command. Attempted to access site and received the same error. I have notified the vendor of your other suggestion and am waiting for his response
Command-results.png
0
 
kingsvilleAuthor Commented:
Used a shorter version of the command suggested:

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

this disabled compression and allowed boht WSUS and application in question to function.

thanks for all the help!
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now