Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 332
  • Last Modified:

SQLServer Agent does not automatically start.

I am using SQL server 2008 and it is hosted on a XP Pro SP3 machine.
The XP host is a Vmware "pc'.
The Sql Server Agent never starts automatically upon logon, i have set it start automatically but always have to manually do it. even though it is set to auto. However when i right click on it and click "start" it starts fine. So the password is ok.

In the Event Log it says that "The Sql Server agent could not start for the reason (unable to connect to the server). Event ID 103
0
MichaelK2
Asked:
MichaelK2
  • 3
  • 3
  • 2
1 Solution
 
theruckCommented:
set the startup to automatic (delayed start) or set the dependency service to be the sql server
0
 
MichaelK2Author Commented:
How do i set it to auto (delayed start), it is just on plain auto now.
Also where is the dependency service in SQL?
0
 
Srm74Commented:
Just to add to theruck...

You do this in Services.
Locate "SQL Server Agent (SQLSERVER)"  in the list and select properties..

0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
MichaelK2Author Commented:
Yes, i know where to find the services (in the confiiguration manager).
But TheRuck is taliking about auto (delayed start), is that different to just plain auto as i do not see any place to choose "delayed start"'? I just see auto, stopped and disable.
The main sql server service is already set as a dependenciy for the agent service.  
0
 
theruckCommented:
it depends on what os you have. XP does not have this option. sorry to mislead you
0
 
Srm74Commented:
You set auto (delayed start) in General Path (Startup type).

to set dependencies see Set Dependencies
0
 
Srm74Commented:
Since you are running XP, just try adding the dependency..
0
 
MichaelK2Author Commented:
Srm74 gave the solution.
It was through the link in his suggestion that explained about adding a service through the registry.
I added the Spooler service to the DependOnService and it seemed to the trick.
The Messenger service is always disabled by default and most of the companys I have worked at never use it and have it disabled.
To TheRuck....thanks for trying Bud, but I feel that Srm74 really pointed me in the right direction.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now