How to kill a bad discovery search?

I made the mistake of including too many search criteria into an "All Mailboxes" discovery search.  Since I started the search yesterday msftesql.exe has been running at 80% utilization even though the search officially "timed out."  Reboot did not solve the problem.  

How do I kill this rogue search?  I'm unable to stop it via the /ecp reporting tab because as far as its concerned the search has timed out and died.
zenthemightyAsked:
Who is Participating?
 
lucid8Connect With a Mentor Commented:
Assume you are talking about Exchange 2010?  if so...

Stop-MailboxSearch -Name "DiscoveryName"

http://technet.microsoft.com/en-us/library/dd335090.aspx
0
 
zenthemightyConnect With a Mentor Author Commented:
Lucid8,

Thanks for the reply.  I had tried that already and as far as Exchange was concerned, the search was stopped.  Problem was that it didn't tell the indexer to stop.   I tried stopping the indexing service but it wouldn't stop, so I finally set it to manual and just killed the process.   I then bounced the server gave it a couple minutes to do its thing, and then restarted the indexing service.  All appears to be well now.
0
 
lucid8Commented:
Very odd...How long did you wait post STOP command?  sometimes there is a buffer and it takes time to stop, other times you have to do the brute force method you employed!  Tech is frustrating at times eh?
0
 
Delphineous SilverwingGood Ol' GeekCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.