?
Solved

ESXI & SSD - drive disappears

Posted on 2011-10-12
15
Medium Priority
?
2,437 Views
Last Modified: 2012-05-12
first time evaluating ESXI 5.  Installed on a Dell R210 on 4GB USB flash drive for ESXI.  Installed Crucial m4 SSD for storage of VM.  Worked OK during 2 days of testing.  _Very_ fast OS installation and boot up.

After OS installed & patched, make a snapshot called "before apps".
Then, started to install apps for users.
After a few items installed & tested, wanted to delete the snapshot.  Took 5 minutes to get to 25%.  10 minutes to get to 50%.  Stayed at 75% for over an hour, then I had to leave.  I left it to run overnight.

This was a <30 of 40GB used on the VM guest's drive.  It was the only VM on a 256GB SSD.

A 500MB application installation took about 1-1.5 minutes.  Why did this deletion of the snapshot take so long.

This morning, the VM is "unknown (inaccessible)".  I was going to assume it was toast, and figure out how to wipe/reprovision the SSD & start over again...but the SSD is no longer listed as a datastore.  The only things availble to me are a SATA HDD and an NFS store where I put ISO images for the VM guests.

What did I do to kill the SSD or take it offline?  Is it likely that the ESXI installation is trashed, or that I trashed the SSD?  Or a hardware failure not caused by me.

I'm not heartbroken over losing either the ESXI install or the VM guest...it was a first run at testing.  But, I'm lost as how to troubleshoot.
0
Comment
Question by:aleghart
  • 9
  • 6
15 Comments
 
LVL 124
ID: 36958871
Your SSD has had a possible hardware failure.

Check with Crucial if it requires a flash update to meet the specifications of your storage controller.

We've had approximately 24 SSD fail at present, including OCZ Revo Drive PCI-E cards.
0
 
LVL 124
ID: 36958895
Personally, I would not install ESXi onto an SSD to costly storage, especially when ESXi just boots the code into memory.

I would install ESXi onto a USB flash drive or SD card.

Here is the VMware KB on installing 4.1 on USB/SD:
http://kb.vmware.com/kb/1020655

Here is the VMware KB on installing 5.0 on USB/SD:
http://kb.vmware.com/kb/2004784

I would then just use the SSD for Datastore or SWAP.
0
 
LVL 124
ID: 36958913
If you had installed the ESXi installation on USB as stated, your ESXI installation is safe, but your SSD datastore, appears to have had a failure.

Is it still visible on the SATA controller at BOOT-UP?

Can you run any Crucial utilities to check if the SSD is okay?

Do you know how large the snapshot was? These can take many hours to remove depending upon size and speed.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 32

Author Comment

by:aleghart
ID: 36958943
Am I better off at this point using Server 2008 and OS RAID 1?

No fancy controller...just the onboard SATA.
0
 
LVL 124
ID: 36958961
RAID 1 two disks SATA, performance IOPS, will be very poor.

Each SATA 7,200 rpm disk, is going to only give 50-80 per disk!
0
 
LVL 124

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 2000 total points
ID: 36958968
Personally, you would be better, creating a NFS or iSCSI NAS with Four disks, with Solaris 11 Express, Openindiana, Nexenta, ZFS (iSCSI or NFS) performance would be far superior with two RAID 1 disks.
0
 
LVL 32

Author Comment

by:aleghart
ID: 36959079
I was thinking RAID 1 with 2x 256GB SSD, not using 7200rpm drives.

Although, for the light load of terminal server, we're doing fine on an old 1.5Gbps SATA drive, installed natively on a PentiumD server.

I figured with wear on the SSD, I could still get 2 years on a heavily-hit drive.  5 years on a moderately used drive like a terminal server and print server, etc.

Next step:  full power off.  Now, the SSD shows up again.  It didn't after reboots.  Not sure what to think from this turn of events.

I created a new VM. Pointed it to the existing drive.  Booting to "Windows Error Recovery" asking if I want to boot normally.

I'll have to see where it sits with the snapshot.  Do I have apps, or reverted back to snapshot point "before apps".

This doesn't make me feel any better about running as a VM.  It's more fragile now than installing straight onto bare metal server.
0
 
LVL 32

Author Comment

by:aleghart
ID: 36959109
OK, didn't boot normally.  Got the Windows splash screen, but shortly got a black screen with no progress.  It should have booted up in a about 30 seconds.

Trying "safe mode".

Nope.  Goes to black screen.

I believe the VM guest is toast.
0
 
LVL 124
ID: 36959165
Weve been seeing more issues lately with SSD, even on physical servers, e.g Win2k8 installation, quick install to SSD, completed all Windows updates, shutdown and restarted, it sat configuring updates for 24 hours, restart the server and the OS was toast.

We still do not understand why, using Corsair Force SSDs and OCZ!

We have now moved all our SSDs into our storage servers and present iSCSI and NFS to ESXi.
0
 
LVL 32

Author Comment

by:aleghart
ID: 36959313
Using ZFS with the SSDs?
0
 
LVL 124
ID: 36959326
Yes, ZFS with SSDs, and ZFS L2ARC cache SSDs, ZIL - SSDs

We've also got standard 7,200rpm drives ZFS, but using L2ARC and ZIL - SSDs, and Logs.

Fantastic speeds, for NFS, iSCSI shareds storage.

Faster IOPS via iSCSI than using local SATA disks in servers!

We've been taking standard HP ProLiant MicroServers (£84 in the UK after cashback) and turning them into SuperSSD SANs for use with ESXi! (and they run at 64 Watts of electric!)

0
 
LVL 32

Author Comment

by:aleghart
ID: 36960228
Ok...getting off-topic, buy how did you get the 6 SSDs attached if the 4 onboard SATA ports ate still available?

I may have to abandon local SSD if the are so troublesome.
0
 
LVL 124
ID: 36961340
LSI SAS 9211-8i

or

LSI SAS3081E-R

(but the MicroServer can have up to a total of 6 SATA in use, from it's motherboard, 4 on the Mini-SAS, and additional 2 - SATA on motherboard, 1 - esata on motherboard)

0
 
LVL 32

Author Closing Comment

by:aleghart
ID: 37097673
I think I'll test install OpenIndiana or Solaris Express 11.  Not sure how they will handle monitoring the RAID (alerting, etc.).  Can't flash the drive lights like I'm used to with older servers & SCSI RAIDs.

I may post another Q about straight OS  versus  ESXI with controller/drives passed through to a VM.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
Advanced tutorial on how to run the esxtop command to capture a batch file in csv format in order to export the file and use it for performance analysis. He demonstrates how to download the file using a vSphere web client (or vSphere client) and exp…
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question