Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 358
  • Last Modified:

Http ERROR 404 AND POST VERB

I am using Visual Studio Express 2010. In my site, I have several folders and all my pages can find the correct images and etc.
However, I have a page that contains a form and below is the line of coding:
<form action="docs/validate.asp" method="post" name="Form1" onSubmit="return checkfields();">

But I recieve this error and don't understand why.

The HTTP verb POST used to access path '/MyNuWeb/docs/validate.asp' is not allowed.

Why am I receiving this? The page that contains the form and calling 'validate.asp' was originaly developed in Dreamweaver MX 2003.
0
Overthere
Asked:
Overthere
  • 3
  • 3
2 Solutions
 
sjklein42Commented:
First thing to try is to change "POST" to "GET" in the <form> tag, and hope that the CGI script will accept either.  If that works, you're good.  If not, we need to figure out how to enable POSTs for your website.
0
 
QPRCommented:
Do you have access to your web server or is hosted elsewhere?
If you can and it's IIS then go to the config in IIS, go to the asp extension and ensure POST is listed
0
 
OverthereAuthor Commented:
I am using my local machine as sever and to develope upon. I have IIS 7 and I have looked in IIS from the control panel and can't figure out where to go to do so. Could you provide me with more help?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
OverthereAuthor Commented:
I changed from "post" to "get" and received the same error!
0
 
sjklein42Commented:
Try renaming your script from .asp to .aspx (and change the URL to docs/validate.aspx) to see if POST is already enabled for aspx files.

Also be sure you have URL Rewriting turned off.

If you care to see, there is lots of discussion about this error message:

http://www.google.com/search?q=iis+asp+enable+post&hl=en&safe=off&sa=N&num=20&output=search&tbs=sts%3A1&tbo=1#sclient=psy-ab&hl=en&safe=off&tbo=1&source=hp&q=iis+%22HTTP+verb+POST%22&pbx=1&oq=iis+%22HTTP+verb+POST%22&aq=f&aqi=g-v2&aql=1&gs_sm=e&gs_upl=83798l90001l0l90438l11l10l1l0l0l3l344l2375l0.2.6.2l11l0&bav=on.2,or.r_gc.r_pw.,cf.osb&fp=9231f99d00f00123&biw=952&bih=1068
0
 
sjklein42Commented:
I am not an IIS expert (@QPR, feel free to help!), but here are Microsoft instructions for enabling protocols:

http://support.microsoft.com/kb/819267

HTTP GET and HTTP POST may be enabled by editing the Web.config file for the vroot where the Web service resides. The following configuration enables both HTTP GET and HTTP POST:

<configuration>
    <system.web>
    <webServices>
        <protocols>
            <add name="HttpGet"/>
            <add name="HttpPost"/>
        </protocols>
    </webServices>
    </system.web>
</configuration>

Alternatively, you can enable these protocols for all Web services on the computer by editing the <protocols> section in Machine.config. The following example enables HTTP GET, HTTP POST, and also SOAP and HTTP POST from localhost:

<protocols>
      <add name="HttpSoap"/>
      <add name="HttpPost"/>
      <add name="HttpGet"/>
      <add name="HttpPostLocalhost"/>
      <!-- Documentation enables the documentation/test pages -->
      <add name="Documentation"/>
</protocols>
0
 
OverthereAuthor Commented:
I tried both things and it was still a no go. I ended up recreating the page as a aspx page and it works. Thanks anyway for helping. It's going to be a long night...sigh
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now