• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 544
  • Last Modified:

Why has my browser suddenly started freezing?

Preliminaries:
OS: Windows 7 Home Premium 64-bit
Browser: Firefox 7.0.1
Add-ons:
   Evernote Web Clipper 5.0.0.177572
   Firebug 1.8.3
   FireStatus 1.10
   Greasemonkey 0.9.12
   Web Developer 1.1.9
   Xmarks 4.0.0
   Zotero 2.1.10

PROBLEM:
My browser has suddenly started freezing sometimes for more than 60 seconds with the spinning icon. Then it will go back to normal. I tried reinstalling Firefox. I have cleaned out all the cache and cleaned up my computer in general, but the problem persists.

Anyone know why this might be happening and what I can [It just did it as I was typing this question] do about it?

Oh... I also ran Spybot thinking it might be a spy program, but it found nothing.

gsw
0
drgreg1408
Asked:
drgreg1408
1 Solution
 
Gaurav SinghSolution ArchitectCommented:
this is the issue with the latest version of Firefox. It also hangs up with me..you will need to provide feed back to firefox team... also latest releases for Firefox are consuming more memory..you can also check this and write then about this
0
 
BawerCommented:
drgreg,

Create a new profile as a test to check if your current profile is causing the problems.
See "Basic Troubleshooting: Make a new profile":
https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.
If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.
See:
http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

but whatever, is it compulsory for u to use firefox!!!
do one thing forget firefox & install google chrome from here:
http://www.google.com/chrome

i grantee u would love it ;)
0
 
drgreg1408Author Commented:
Right on spot!

I actually took your advice and tried Chrome but I found that it reinterpreted the number format for a site that I have to enter regularly. I couldn't sign in. So I had to go back to Firefox. but it's working now.

Thanks
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now