• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 561
  • Last Modified:

Microsoft NLB not working

Hi

I installed 4 node exchange in Virtual environment (Hyper-V). Each physical Node has 2 VM

Host1

(VM1) Exchange 2010 MB-1, (VM2)- Exchange 2010 CAS/HUB-1

Host2

(VM1) Exchange 2010 MB-2, (VM2)- Exchange 2010 CAS/HUB-2

We did a NLB between Exchange 2010 CAS/HUB-1 & CAS/HUB-2

I add the first node to NLB it seems Works fine, and it shows Converged(which is correct)

When i try to add the second node, the Additional was succesfull,but it always show Converging(This is the problem)

if i suspend the node1 and start the Node2,it showing Converged , when i try to start the node1, now node1 become coverging

So in total, my NLB works like Failover instead of Network load balancing

Regards

Ramkumar.A

0
ramkumara
Asked:
ramkumara
  • 4
  • 2
  • 2
  • +1
1 Solution
 
AkhaterCommented:
since you are in HyperV you need to make sure you enabled mac address spoofing on the hyperV image for the NIC you are going to implement NLB on
0
 
RadweldCommented:
Hi there, how did you configure your NLB? With multicast or unicast?

Have a quick read through this document first to make sure it's configured.

http://technet.microsoft.com/en-us/library/bb633031.aspx
0
 
ramkumaraAuthor Commented:
Hi,
Yes MAC address spoofing is enabled on Hyperv Host level
We configure the NLB with Unicast

Please note the customer using third party DNS, instead of Microsoft DNS.
 
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
AkhaterCommented:
how did you enable mac address spoofing? can you share a screenshot please? this is typical mac address spoofing symptom
0
 
RadweldCommented:
I would reconfigure to use a single nic and multicast.
0
 
sumit_aroraCommented:
Exchange 2007 CAS NLB on server 2008
http://social.technet.microsoft.com/Forums/en/exchangesvrdeploy/thread/f85663cc-5afd-401d-a320-fff0346e37ed

However, with Hyper-V, WNLB and Unicast, you might also run into other issues:

Exchange 2007 Unicast NLB Issue on Hyper-V
http://www.shudnow.net/2008/09/12/exchange-2007-unicast-nlb-issue-on-hyper-v/


--------------------------------------------------------------------------------
0
 
ramkumaraAuthor Commented:
Atttached MAC address spoofing screen shot,

The current setup is one to one network mapping(i.e physical to virtual). There is no teaming has been done at host level.

Hyper-V-Setting.jpg
0
 
ramkumaraAuthor Commented:
Hi

we found the Root cause of the issue is particular Physical Network Port. when i change the Virtual network to another physical port , everything works

Regards

Ramkumar.A
0
 
sumit_aroraCommented:
Good to hear that, cheers
0
 
ramkumaraAuthor Commented:
The problem was due to Physical network port issue, after several troubleshoot , we find it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now