• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

Follow up on auto deletion policy on exchange 2003 server

I tried running deletion policy for delete immediately for one user only. It presently is priority #2. It didin't delete the older emails that were older than 365 days.
I am including print screens of mailbox policy and advanced for username selection.
I had closed the question cause I thought it by following the kb article I would be all set, but it didn't run successfully.
Also when I am sure that user 46-spare emails are deleted sucessfully by policy, then I want to run it for all users. What criteria do I use, If i leave it blank then I assume it will run for all mailbox users
ScreenShot359.jpg
0
jim3725
Asked:
jim3725
  • 8
  • 4
1 Solution
 
jim3725Author Commented:
0
 
endital1097Commented:
Once you create this policy you need to go to the properties of your mailbox server(s) and select the Mailbox Management tab
There you will schedule your mailbox management process
0
 
jim3725Author Commented:
I already have a schedule customized for anothe policy.
see attachment
ScreenShot365.jpg
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
jim3725Author Commented:
also schedule is attached here for 11pm
ScreenShot366.jpg
0
 
endital1097Commented:
any errors in the application log? you can also have reporting enabled and sent to an admin mailbox
0
 
jim3725Author Commented:
I get messages sent from my first policy priority 1 sucessfully. No errors in app log
0
 
endital1097Commented:
make sure that the first policy does not apply to this mailbox otherwise it will stop processing and never hit the second
0
 
jim3725Author Commented:
I changed the priority on policies  so that 1yr deletion for user 46-spare1 runs first.
I will update ticket tomorrow to see if it works.

0
 
jim3725Author Commented:
Still no difference on deleting older messages on the one user, after I changed priority on policy to run first. I really need to have all mailboxes have their messages deleted after 1yr but I want to make sure it works for atleast one user before I run it.
0
 
endital1097Commented:
did you get a report for this policy when it ran
0
 
jim3725Author Commented:
No i did not, only on the 30day deletetion policy do I get a report on.
0
 
jim3725Author Commented:
Once I changed valued on modified date, through adedit  then autodeletion policy work correctly
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now