• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 286
  • Last Modified:

cisco asa 5505

Hi
I have just set up a new ASA 5505 unit in a remote office with the ASDM, I have created a site to site link which connects and replication between servers is working but now I can’t ping the asa from within the network so the ASDM software won’t connect and also I cannot receive the internet inside the network. The server is the DHCP  

Can someone help me with the command line I would need to connect to the asa from within the ASDM as I can connect through serial port still.
0
dances1960
Asked:
dances1960
  • 5
  • 5
1 Solution
 
Ernie BeekCommented:
Could you show us a sanitized config to start with?
0
 
dances1960Author Commented:
Hi Sorry that would help :)

 nameif inside
 security-level 100
 ip address 192.168.8.86 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 195.1.1.1 255.255.255.248
!
ftp mode passive
dns server-group DefaultDNS
 domain-name phxent.local
object-group service DM_INLINE_SERVICE_1
 service-object tcp eq domain
 service-object udp eq domain
access-list inside_access_in extended permit tcp any any eq https
access-list inside_access_in extended permit udp any any eq isakmp
access-list inside_access_in extended permit ip 192.168.0.0 255.255.255.0 192.168.8.0 255.255.255.0
access-list inside_access_in extended permit ip 192.168.8.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 any any
access-list inside_access_in extended permit tcp any any eq www
access-list outside_cryptomap extended permit ip 192.168.8.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list inside_1_cryptomap extended permit ip 192.168.8.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.8.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (inside) 0 192.168.0.0 255.255.255.0 outside
static (inside,outside) 192.168.0.0 192.168.8.0 netmask 255.255.255.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 195.1.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.8.0 255.255.255.255 inside
http 192.168.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map1 1 match address outside_cryptomap
crypto map outside_map1 1 set pfs group5
crypto map outside_map1 1 set peer 194.7.1.178
crypto map outside_map1 1 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map1 interface outside
crypto map inside_map 1 match address inside_1_cryptomap
crypto map inside_map 1 set pfs group1
crypto map inside_map 1 set peer 194.7.1.178
crypto map inside_map 1 set transform-set ESP-3DES-SHA
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
 vpn-tunnel-protocol IPSec
tunnel-group 194.7.1.8 type ipsec-l2l
tunnel-group 194.7.1.178 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:a051c7909a33f258b8569a706ea05711
0
 
Ernie BeekCommented:
First, for the internet access try removing:
nat (inside) 0 192.168.0.0 255.255.255.0 outside
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 192.168.0.0 192.168.8.0 netmask 255.255.255.0
And add:
nat (inside) 1 192.168.8.0 255.255.255.0
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
Ernie BeekCommented:
For ASDM try adding: http 192.168.0.0 255.255.255.0 outside (assuming 192.168.0.0 is the remote net).
0
 
dances1960Author Commented:

I've added the config you posted and so far no change, the intenal network here is 192.168.8.0 and the remote site which still is connected is 192.168.0.0
I have noticed that even with my laptop connected to the asa directly I cannot ping the ip address of it, which is 192.168.8.86. Yet i can remote to main office through it and at present I am using the proxy address of the main office on this laptop to connect on the internet.
also while I have added the config of your first post I am unable to correctly add the http one
0
 
Ernie BeekCommented:
Ok,
First try adding:
policy-map global_policy
 class inspection_default
  inspect icmp

If you still can't ping, add: access-list inside_access_in extended permit icmp any any

So you are now in the 192.168.8.0 network?
0
 
dances1960Author Commented:
yes sorry i am in the remote office now on the 192.168.8.0 network but using the internet through the proxy on the 192.168.0.0 network.
will add config now and reply shortly
0
 
dances1960Author Commented:
sorry didn't post anymore lost all connections after I entred the lines, will I think re set it tomorrow and try again
0
 
Ernie BeekCommented:
Mmm, that shouldn't happen when just adding an icmp inspect......
Let me know when you're trying again.
0
 
dances1960Author Commented:
will do and thank you for the help so far
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now