[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

The semaphore timeout period has expired

Posted on 2011-10-13
2
Medium Priority
?
1,352 Views
Last Modified: 2012-05-12
I am continually encountering the message "The semaphore timeout period has expired" when trying to access one of my SQL Server Databases.  Searching on the internet this seems to be usually related to networking issues, but in my case it is definately not networking.  The database is running locally.  I think it is possible that there is some sort of file corruption problem a the root of it.

A few days ago my house blew a fuse and my computer went down while doing some intensive sql server updates.  Since then I've had data corruption issues which had seemingly been fixed by using DBCC CheckDB (0, Repair_Allow_Data_Loss).  However now I am encountering "semaphore timeout period has expired" errors regularly.  I did a backup of my development directory and about 20 files could not be copied because of this error (luckily none were importtant).  When re-attempting the backup it was always the same (random) files that could not be copied which is why I think it is a data corruption issue.

On the database in question, I am able to access most of the tables, but (at least) one of the tables throws up the error.  Also if I try to do a backup of that database I receive the error.  I have tried ChkDsk (no errors) and DBCC CheckDB (errors on the initial run, but once they were repaired no more errors).  Searching on the internet has got me nowhere, most of the threads start with the quote "searching on the internet has got me nowhere"!

Other relevant facts are that the "computer" is a high spec laptop using SSD drives.  And also that a couple of weeks ago there was an overnight freak storm, where after a sunny day literally horizantal rain must have come through an open window and shorted the electric connections and wet the laptop.  The battery on the laptop no longer works (I have to run on power supply) and the one of the USB ports no longer works, which suggests some pretty significant damage.  Afterwards I though everything was ok, but I didn't backup this database (it is just temporary loading database) and since I had thought my file system was being continuously backed up over the internet I didn't check it until today. (word of note, never use SugarSync ever!! - I just discovered that,  after it telling me that all my files were correctly synced, it doesn't appear to have synced anything for almost 2 months.  I'm glad I discovered now and not when I had lost everything).

0
Comment
Question by:eb8931
  • 2
2 Comments
 

Accepted Solution

by:
eb8931 earned 0 total points
ID: 36963282
I have found a way around this solution.  I truncated or deleted all the unnecessary tables in the database (it's just a temporary loading table) and also did a re-index and a shrink of the database files.  Basically just anything I could think of that might reduce or move the file contents around.  And now it is working.  I'm not sure which step fixed it.

I'll leave this question open for a few days, since I'm quite worried I might encounter it again.  If anyone feels like answering it would be appreciated, but there is absolutely no urgency any more to it.
0
 

Author Closing Comment

by:eb8931
ID: 37011209
Problem resolved
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
In this article we will get to know that how can we recover deleted data if it happens accidently. We really can recover deleted rows if we know the time when data is deleted by using the transaction log.
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question