Remove footer from report

I created a report using InfoView, and want to export it as Excel, but the Excel file always ends up with an empty row at the bottom.  Since I import the data from this excel spreadsheet into Access, the import process fails because the empty row does not meet the constraint requirements.  

On the report block/table within InfoView, I unchecked Show Table Footers.  In Page Layout/Relative Position, I changed left edge and top edge to 0 (which eliminated the empty row and column at the beginning), and unchecked all of the boxes including Repeat footer on every page.

How do I eliminate the empty row at the bottom?

I also tried exporting the data from InfoView as a text/csv file, but that process only pulls the results of the query, not the report, so any calculated fields are not included in the result colums.  If anyone knows a way to force it to include the calculated fields, that would be an acceptable work around.

As an alternative work around, if anyone knows how to supress the error message when I try to import the data with the empty row into Access, that would be acceptable as well.  I actually have a table linked to these data outside of Access and then run a query to insert into a table, and it is this insert process that gives me the error message.  I have supressed alerts via the Access Options under Advanced, but the message I receive is asking me if I want to continue the insert statement and ignore the empty row, or cancel the insert altogether.  I would be fine with ignoring the empty row but I cannot figure out how to automate this.  

I am using Excel and Access 2007.  I don't know what version of InfoView we are using but when I click on About it says 12.1.0.  
tancatOracle DeveloperAsked:
Who is Participating?
 
Rey Obrero (Capricorn1)Commented:
<If anyone knows a way to force it to include the calculated fields, that would be an acceptable work around.>

use a query with columns that do the calculations.

< I actually have a table linked to these data outside of Access and then run a query to insert into a table, and it is this insert process that gives me the error message>

modify your query to have a criteria that will not include the empty rows..

                  where [KeyField] <> Null
0
 
tancatOracle DeveloperAuthor Commented:
Thank you for reminding me to take a break and walk away for a while - your second solution worked, and was so simple I can't believe I didn't think of it myself, but this project has been dogging me for the last three days.  

Your first solution probably would have worked, too, but since I am no longer part of our corporate IT, I no longer have access to create custom queries - I am limited to existing objects only. :-(  

Thank you!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.