[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 377
  • Last Modified:

Changed root password now ssh won't accept logins

I changed my root password and rebooted and now for some reason the ssh server is not accepting any logins. Just says the password is incorrect. What could be causing this?

Ubuntu 10.04
0
steiner470
Asked:
steiner470
1 Solution
 
sentnerCommented:
Is it just the root account that cannot log in via SSH, or are regular users also unable to log in?  Also, how long has it been since you last rebooted, as it may have been the reboot that caused the issue, rather than being related to the root password changing.



0
 
peter197911Commented:
Try to prevent to login with root account to ssh sessions.... Most admins do close this option in sshd config (PermitRootlogin=no).

No typo's made with choosing a new rootpass?  No capslock, numlock, ....???? no idea what.
Check indeed if a normal user can login or not.
And can't you login (do you get a prompt and it refused you're username password) or do try to connect and it just doesnt connect....???

If it doesnt connect --> you have local access to the machine >> ssh daemon started ???
0
 
steiner470Author Commented:
@Senter - No accounts are working any more. They all say incorrect password. Its been a while since I last rebooted but not much has changed since then.

@Peter - PermitRootLogin is set to yes. I'm not making any typos. I can login as root or regular user fine directly from the terminal, just not SSH. When I try to connect via SSH I do indeed get a prompt for username and password. I type in a known username and pass of an SSH user and it tells me the password is incorrect.

So strange.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
steiner470Author Commented:
Wait, sorry, I made a mistake... it not seems that ONLY the root login is not being accepted into SSH. Other users are working fine... Mmmm... I can login as root directly from the terminal and PermitRootLogin is set to yes... what else could it be...?
0
 
RHochstenbachCommented:
Could you check your /var/log/auth.log file for any clues?
0
 
steiner470Author Commented:
Turns out if you add the allowusers parameter in sshd config file then you have to specify root a second time
0
 
sentnerCommented:
I'm more versed on Solaris, but on there, you set whether root can directly log in remotely by the CONSOLE variable in /etc/default/login.... I'm guessing linux likely has a similar setting somewhere.  
0
 
sentnerCommented:
Disregard last post... You posted your conclusion even as I was typing my last reply.  :)
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now