Windows Loader Error 3

Posted on 2011-10-13
Last Modified: 2012-05-12
Hello everyone, I am experiencing a "Windows Loader Error 3" upon bootup.

This is in a Corporate environment. I am using a HP 8200 Elite model PC. This is happening on almost every one of these model PC's we use.

We use a fresh image on the system, which includes Windows XP Professional, Adobe Reader 9.3, Java 2.4 and a client Uniprint v4.0, as well as Office Professional 2003.

We need these revisions for our corporate EMR software. We apply Express Windows updates.

We are trying to deploy these units at our sites, but, as soon as Windows updates are finished installing, we reboot, and are INSTANTLY experiencing this error prior to seeing the Windows XP "splash" screen.

We have tried many things including different images, different users installing the image etc, with no luck.

By no luck, we can do a system restore which provides TEMPORARY relief to the issue. We reboot and it can also cause the error to temporarily disappear.

I am suspect of this being a hardware / sata issue, but the confounding thing is, we have several units in the field which are not affected.

We do suspect some sort of rogue Microsoft update, but other identical units have received matching updates and are working perfectly fine.

The bottom line is, there appears to be no commonality / common denominator in this to follow up on.

Anyone that can provide us assistance with this would be greatly apprecated.


Joe Foster
Question by:trivalent
    LVL 66

    Expert Comment

    The only thing I can offer at this point, is that we have just started getting 8200s, and the UEFI BIOS has been causing us issues in building an image via MDT...... Not a solution I know, just subscribing to this thread so I can see how it turns out....
    LVL 37

    Expert Comment

    by:Gerwin Jansen
    Hello Joe, I've been searching for you and cannot find a solution for an XP based system. One W2K user had replaced NTLDR with a good one, this worked but not for another user. I also found 1 case where the issue was a graphics driver (W2K again), that user restarted with debug logging and saw the boot process halt at AGP440.sys - all found here. Maybe that case can help you debugging your issue, then again that case is on a W2K system so I'm not sure if it'll work for you.
    LVL 33

    Expert Comment

    Another vote for possible Graphic driver. A quick look shows them using one of these videos...
    Integrated Intel HD 2000/3000
    ATI Radeon HD 5450 (512 MB)

    Try uninstalling and hiding the KB2393802 update.


    Check out the Known Issues from this page
    It states
    "Certain systems that have Intel HD graphics cards or AMD ATI HD graphics cards may crash after this security update is installed. Microsoft has investigated this issue in partnership with both Intel and AMD. We have identified an incompatibility between this update and certain older versions of the Intel and AMD graphics drivers. Both Intel and AMD have posted updated drivers that resolve this issue. "

    LVL 1

    Accepted Solution

    Actually, I believe I found the solution.

    I did not want to have to resort to this, but, I went out to HP's website and saw that our BIOS 6/11 was updated to 7/11. So, I flashed it, and now have rebooted multiple times with 0 errors. So, I'm going to continue testing the system to ensure it's stable, but it looks like this is the permanent solution I'm looking for.

    LVL 1

    Author Closing Comment

    I resolved this myself.
    LVL 37

    Expert Comment

    by:Gerwin Jansen
    This is from the BIOS update information:

    - Fixes an issue where Bitlocker could generate an error message if waking up
    from the network remotely.
    - Fixes a system hang caused by Windows Management Interface (WMI) queries when
    booting from an EFI boot source.
    - Fixes an issue where the system can sometimes hang with a gray screen when
    entering Computer Setup (F10) if a PCI card with an active option ROM is

    I would not have guessed this would fix your Windows Load Error #3
    LVL 33

    Expert Comment

    Interesting.  Thanks for the feedback.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now