Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1057
  • Last Modified:

can't ping a point-to-point interface over frame relay

hello,

i created a frame relay network and configured 2 routers using point-to-point sub-interfaces everything is UP but i cannot ping, here is the config:

Router1:

R1#show run
Building configuration...

*Mar  1 00:56:36.267: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 10.1.13.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial1/0.103 point-to-point
 ip address 10.1.13.1 255.255.255.0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!        
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R1#


-----------------------------

Router2:


R3#show run
Building configuration...

Current configuration : 1021 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.103.3 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 10.1.13.1 301 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1.301 point-to-point
 ip address 10.1.13.3 255.255.255.0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 10.1.35.3 255.255.255.0
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!        
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R3#


--------------------------------

Frame Relay Switch config :

FR1#show run
Building configuration...

Current configuration : 984 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FR1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
frame-relay switching
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 103 interface Serial0/1 301
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

FR1#


thank you


0
World05
Asked:
World05
  • 2
1 Solution
 
World05Author Commented:
R1#show frame map
Serial1/0 (up): ip 10.1.13.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
R1#


R3#show frame map
Serial0/1 (up): ip 10.1.13.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active
R3#

FR1#show frame route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0/0       103             Serial0/1       301             active
Serial0/1       301             Serial0/0       103             active
0
 
zakar1aCommented:
it's obvious, remove these statements from your 2 routers :

frame-relay map ip 10.1.13.3 103 broadcast
frame-relay map ip 10.1.13.1 301 broadcast

go to your sub interface and add the following:

On R1:
frame-relay interface-dlci 103
On R3:
frame-relay interface-dlci 301

that's it
0
 
World05Author Commented:
thx, it worked
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now