Xenapp 6 published desktop annoying message

I have created ICA launch files for our internal users. This Launches a Server Desktop (Published Desktop).

When the desktop has loaded, I see this annoying message every time
 ICA Error
I have researched and all posts talk about errors, but is it an Error? Everything works great. To me this is just stating the obvious that I have launched a published explorer desktop.

I would really like to get rid of this message.  
MayogroupAsked:
Who is Participating?
 
Dirk KotteConnect With a Mentor SECommented:
uninstall the citrix client at one desktop and launch the application from the webinterface.
you should be possible to download and save the launch.ica file.
compare this file with you .ica file.
0
 
MayogroupAuthor Commented:
Just to add. If I launch the same Published Server desktop from the Citrix Web interface, this msg does not appear. It's only when launching from the ICA launcher.

Launcher file includes the following details:


[Encoding]
InputEncoding=ISO8859_1

[WFClient]
Version=2
HttpBrowserAddress=My server IP Address:8080


[ApplicationServers]
NSW Desktop=

[NSW Desktop]
Address=NSW Desktop
InitialProgram=#NSW Desktop
ClientAudio=On
AudioBandwidthLimit=2
TWIMode=On
DesiredColor=24
DesiredHRes=800
DesiredVRes=600
Compress=On
TransportDriver=TCP/IP
WinStationDriver=ICA 3.0
BrowserProtocol=HTTPonTCP

[Compress]
DriverName= PDCOMP.DLL
DriverNameWin16= PDCOMPW.DLL
DriverNameWin32= PDCOMPN.DLL
0
 
MayogroupAuthor Commented:
Im not sure what I should be looking for. They are totally different.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Dirk KotteConnect With a Mentor SECommented:
can you please post this file also
than i can take a look
0
 
MayogroupAuthor Commented:
See below. If I save this to my desktop and try launch it, it just disappears.
Also this ICA launcher is pointing to my CWI/SAG. The launcher with the error points directly to my primary Xenapp server.


[Encoding]
InputEncoding=UTF8

[WFClient]
CPMAllowed=On
ProxyFavorIEConnectionSetting=Yes
ProxyTimeout=30000
ProxyType=Auto
ProxyUseFQDN=Off
RemoveICAFile=yes
TransparentKeyPassthrough=FullScreenOnly
TransportReconnectEnabled=Off
VSLAllowed=On
Version=2
VirtualCOMPortEmulation=Off

[ApplicationServers]
NSW Desktop=

[NSW Desktop]
Address=;40;STA00505699001C;278F620520C4D37D16ADAEF11CB89DDA
AutologonAllowed=ON
BrowserProtocol=HTTPonTCP
CGPSecurityTicket=On
ClearPassword=BC17DB9A954691
ClientAudio=On
DesiredColor=8
DesiredHRES=4294967295
DesiredVRES=4294967295
DoNotUseDefaultCSL=On
Domain=\203C3A7AE836C56A
FontSmoothingType=0
HTTPBrowserAddress=!
InitialProgram=#NSW Desktop
LPWD=0
LaunchReference=4LZ/fHTK53aTVMeq6Nb7q4al93zYF3mh73bMHMIFOkY=
Launcher=WI
LocHttpBrowserAddress=!
LogonTicket=BC17DB9A954691203C3A7AE836C56A
LogonTicketType=CTXS1
LongCommandLine=
NRWD=16
ProxyTimeout=30000
ProxyType=Auto
SFRAllowed=Off
SSLCiphers=all
SSLEnable=On
SSLProxyHost=my Web interface address:443
SecureChannelProtocol=Detect
SessionsharingKey=-bH6WoEazP/oye2c0czdmiD
StartIFDCD=1319023240861
StartSCD=1319023240861
TRWD=0
TWIMode=Off
Title=NSW Desktop
TransportDriver=TCP/IP
WinStationDriver=ICA 3.0

[Compress]
DriverNameWin16=pdcompw.dll
DriverNameWin32=pdcompn.dll

[EncRC5-0]
DriverNameWin16=pdc0w.dll
DriverNameWin32=pdc0n.dll

[EncRC5-128]
DriverNameWin16=pdc128w.dll
DriverNameWin32=pdc128n.dll

[EncRC5-40]
DriverNameWin16=pdc40w.dll
DriverNameWin32=pdc40n.dll

[EncRC5-56]
DriverNameWin16=pdc56w.dll
DriverNameWin32=pdc56n.dll
0
 
KrAzYConnect With a Mentor Commented:
Does one launch as a seamless application and one as a desktop?

It dissapears because of:
RemoveICAFile=yes

You can change it to "no", but the file won't work after a certain period of time because the ticket will expire.

Not sure if you've seen this:
http://support.citrix.com/article/CTX112134
0
 
Dirk KotteConnect With a Mentor SECommented:
the parameter "TWIMode=On" cause the application to run seamless.
try to remove them from your Launcher file.
but a published application should not starting the full desktop.
How do you publish the app?
0
 
MayogroupAuthor Commented:
It's not a published app. It is a published server desktop.
0
 
MayogroupAuthor Commented:
FYI, I remove the TWIMode line and the msg goes away, however the desktop does not open in full screen mode.
0
 
Dirk KotteConnect With a Mentor SECommented:
do you publish the explorer.exe or the desktop?
internaly i use PNAgent to publish the desktop (in full screen mode) many times and i never seen this message.

0
 
MayogroupAuthor Commented:
Publishing the full desktop.
How do you use PNAgent? not familiar with this app.
0
 
Dirk KotteConnect With a Mentor SECommented:
its like the WI but as an app.
the PNA calls his configuration and the aplication list from the WI-Server.
You have to create a WI-Service-Site within the WI-Configuration tool.
it doesn't work with 2 factor authentication like RSA or Safeword.
 
0
 
MayogroupAuthor Commented:
Do you have any details on how to set this up?
0
 
MayogroupAuthor Commented:
I already have the Service site enabled. I use this for the Full Online Plugin for certain users.
Still not sure how to make an ICA launcher to use this however.
0
 
Dirk KotteConnect With a Mentor SECommented:
you have the same message with the users using the "Full Online Plugin "?
0
 
MayogroupAuthor Commented:
nope
0
 
MayogroupAuthor Commented:
I mainly want to use the ICA launcher for our Desktop PC users. I want to set it to launch on Startup.
Laptop users can just use the Web interface.
0
 
Dirk KotteConnect With a Mentor SECommented:
you also can use the PNAgent to start the session while logon.
i don't know the "ICA-Launcher". please tell me more about it.
0
 
MayogroupAuthor Commented:
What is the PNAgent?
0
 
Dirk KotteConnect With a Mentor SECommented:
PNAgent (ProgramNeigborhoodAgent) is the old name fro the Citrix Receiver foe Windows (Andin use only) Version.
It is the same as the "Full Online Plugin"
http://www.citrix.com/English/ss/downloads/details.asp?downloadId=2315305&productId=1689163&ntref=clientcenter

more to read:
http://support.citrix.com/proddocs/topic/receiver-30-windows/ica-receiver-30-windows-wrapper.html
 
0
 
MayogroupAuthor Commented:
I see,
Tried that and it seems to work fine.
Just means for me that I have to redeploy this client to all staff instead of the Web Online Plugin.

Was hoping to be able to make it work with an ICA launcher on the Web Plugin.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.