XP repair in endless reboot / restart loop at 9 minutes remaining - 'configuring components'

Posted on 2011-10-14
Last Modified: 2012-07-05
I was running XP home with SP3. I had a motherboard failure while the PC was in use. I was unable to get another identical one but I have at least been given another motherboard. My goal is to repair my current installation with the new motherboard. I have a lot of programs I use, and it took a long time to get them all configured and so on. I really, really, really do not want to reinstall windows from scratch and have to reinstall all those programs so being able to repair my current installation is a high priority.

Luckily I have some spare hard drives to play with. I had lost my original XP disc and product key some years ago, and it was an upgrade version anyway. I bought a new Dell OEM XP home disc with SP2. On one of my hard drives that has an XP pro installation I used Nlite to slipstream a CD with SP3 and created an 'attended' installation.

On an old, smaller, hard drive that had the same original XP installation that had previously been used on an even older motherboard (I had progressively upgraded to larger hard drives and faster motherboards) I tested the Nlite XP disc and it repaired the installation perfectly. Using it on my current hard drive it got all the way to 'configuring components' with the progress bar right up to the right hand side, and said '9 minutes remaining'. Then the screen went dark for about 15 seconds while there was still quite a bit of disc activity going on, and then rebooted, with 'setup is restarting'. It has done this endlessly.

I've tried three different graphics cards: the latest one that does very occasionally crash with an 'ATI2DVAG..something' error, the previous one that never crashed and for which the drivers were still installed, and the onboard VGA graphics. With the onboard graphics, once windows is passed the windows logo with the running green bar when it's starting up my LCD monitor says 'out of range' and goes black, so I can't see what the hell is going on. This may be because my previous installation had a higher resolution than the onboard VGA graphics card may be able to cope with, so I've been forced to use an external graphics card. but with both graphics cards it does the same thing. When doing the repair installation on the very old hard drive, I had previously had a lower resolution screen configuration and it was able to use the onboard VGA without problem.

installing the hard drive as a secondary drive, I looked at NTBTLOG.txt and it just gave a list of drivers it had installed or not installed. Maybe I stopped the boot at the wrong place and it was giving the results of the reboot before I stopped it rather than the one that failed, I'll check that out.

Can anyone shed light on this kind of behaviour though?
Question by:MikeHersee
    LVL 87

    Expert Comment

    If your mainboard isn't a DELL board, then you can forget this with a DELL OEM CD.

    Also, if your original installation was OEM, you can forget it, as OEM will need identical hardware to work.

    If the above two don't apply, then you can try using Paragon's Adaptive Restore utility to get your installation working again (it's a free tool):

    Author Comment

    Neither the previous motherboards for either of the existing XP hard disks were Dell, and neither is the 'new' motherboard I've just been given, but I've already proven it's possible because as I said, testing the slipstreamed SP3 setup disk with the older hard drive worked perfectly. So I've already proven that 'forget it' is not applicable and it is entirely possible.

    The paragon tool sounds great from reading about it and I wish I'd known about it earlier, but I think now the repair installation has very nearly completed it's too late for this installation. The fact that it reboots and runs through virtually the whole of the repair installation process by itself indicates it can run already on the new hardware - if only it would complete the final bit of the installation process.

    But after posting the original problem I cancelled the rebootling loop at the 'accept terms and conditions' screen by choosing 'don't accept'. This then revealed the existence of the setup error log - c:\windows\setuperr.log. This showed that the two last errors causing it to loop appeared to be these:

    An error occurred while compiling the following MOF file: C:\PROGRAM FILES\MICROSOFT SQL SERVER\100\SHARED\SQLMGMPROVIDERXPSP2UP.MOF  Please refer to C:\WINDOWS\system32\WBEM\Logs\mofcomp.log for more detailed information.


    Setup could not register the OLE Control C:\WINDOWS\system32\macromed\flash\flash.ocx because of the following error:
    DllRegisterServer returned error 2147647516 (8002801c).

    I'm afraid looking at the WMI error left me none the wiser, but it did not appear on the face of it to cause the installtion to crash fatally.

    Although not particularly common, it appears I'm not the only person to have this 8002801c error in these or similar circumstances with the flash file. The iimmediate cause appears to be incorrect registry permissions, but it doesn't say which keys or why. I found various solutions which seemed to depend on your existing installations still booting up and being able to log on to them as administrator. For example, one solution involved installing a utility that logs all the registry keys accessed or setting the logging level to be much more detailed. As mine won't boot because it's in the middle of a repair install I can't do them exactly, or don't know how to do them.

    The adobe website solution appears to require being able to boot into windows still. I did come across this microsoft article which was proposed and apparently worked as an effective solution for one user who was able to boot into windows who had the same problem but when upgrading or install flash:

    It involves installing subinacl and running this batch file.

    @echo off
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=system=f
    @Echo =========================
    @Echo Finished.
    @Echo =========================

    Bizarrely, subinacl was on my XP Home hard disk but in the Serif software folders under Program FIles.

    However, understanding that it was registry permissions I had two approaches to take: Use BartPE and either run regedit or regeditPE, or run the batch file above.

    I found the batch file seemed to work perfectly when I booted into BartPE, but it appeared to work on a temporary version of the registry created when BartPE boots in the X: drive, rather than the one on my hard disk. So one questions is,

    "How do I get it to run on the registry on the hard disk under BartPE?" (or how can I check which version it actually ran on?)

    I was unable to get the batch file to run under the Windows recovery console even when I copied subinacl and the batch file to the windows\system32 folder. It appeared that it wouldn't execute anything that wasn't one of the limited range of commands listed, even when I changed the name in the batch file to 'subinacl.exe' and positioned myself in the windows\system32 directory. So another question is,

    "How do I get the subinacl batch file to run under windows recovery console?"

    The alternative seemed to be to use BartPE and run Regedit or RegeditPE. However, the instructions I found for how to edit the correct copy of the registry were either confusing to me, appeared to be not quite complete or sufficiently detailed for me who has never edited the registry outside of windows before, or were not consistent with my experience. For example, following one set of instructions, where it said to choose 'file --> load hive', the 'load hive' option for me was greyed out for the registry key section I wanted to access. Can someone point me to more helpful instructions for editing the right copy of the registry under BartPE for a less experienced user? or under the recovery console?

    I should mention I've seen a tool on one page that claims to fix those 8002801c errors, but it smelled very suspiciously like malware to me - Am I right to be cautious here?
    LVL 87

    Expert Comment

    Even if it should work with an OEM installation, it is a breach against M$'s EULA, and so not allowed. Also we aren't allowed to help on this site when such EULA breaches are involved. DELL OEM media is only allowed for DELL hardware. You should at least be getting into licensing issues, maybe that just takes some time to emerge.

    Author Comment

    Ok, I wasn't aware that it wasn't even allowed. I thought that it just meant it was not entitled to be repeatedly transferred from one PC to another without buying another licence. According to the company I bought it from it comes with a second-hand PC I can go and pick up to comply with their licensing agreement but there's no obligation to install it on that PC only. I'll have a closer look at it.

    Author Comment

    I see you are correct about the licensing issue. I will have to obtain from the supplier the PC that is offered as part of the deal on which they clearly expect very few people to take them up. They say you can phone to arrange collection. Interestingly, the EULA makes no mention of Dell specifically, it just makes reference to the software only being used with the hardware with which the software was purchased, whatever it is.
    LVL 87

    Expert Comment

    The EULA is from m$, not DELL, so you won't see any mention of DELL inside it. The thing is that OEM software is cheaper than retail software, and for that cheapness m$ built some hooks.

    Accepted Solution

    I decided I'd wasted enough time on it and have reinstalled from scratch

    Author Closing Comment

    Disappointing outcome

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
    We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
    Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now