[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 2408 bytes) in /home/swishclu/public_html/administrator/components/com_phocagallery/libraries/phocagallery/image/imagema

Posted on 2011-10-14
8
Medium Priority
?
1,356 Views
Last Modified: 2012-08-13
Hi There

I have a client who is battling with phocagallery

the moment you go into the images tab you get the following error

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 2408 bytes) in /home/swishclu/public_html/administrator/components/com_phocagallery/libraries/phocagallery/image/imagemagic.php on line 214

this is occuring without even uploading images

Please assist

Thanks
0
Comment
Question by:tyronenoel
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 8

Expert Comment

by:Aegil
ID: 36967602
you need to increase the php memory limit. There will be a directive like the following in the php.ini file

memory_limit = 64M
Change it to 128M or something similar and it should resolve your issue.

The php.ini file is usually in /etc/php5/php.ini. once you have updated this it should resolve your issue. Your web host should be able to help you with this.
0
 
LVL 8

Expert Comment

by:Aegil
ID: 36967608
The below gives more information on doing this. I would recommend changing it globally through the php.ini file


http://www.ducea.com/2008/02/14/increase-php-memory-limit/
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36968655
Another place to look for php.ini on some Linux systems is in /etc/httpd

If you are using Linux (or some other *nix), and you can't find the php.ini file try this

# find  /etc  -name  "php.ini"
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 7

Accepted Solution

by:
ziceva earned 1000 total points
ID: 36968872
Alternatively, if you don't have access to the php.ini file, you have to options:

Modify this parameter at runtime by calling
ini_set('memory_limit','256M');
In the php script (being a joomla platform you could get away with putting this somewhere on the top of index.php)

Second, you could edit/create the file with the name .htaccess in your Document Root and add

php_value memory_limit 256M
0
 
LVL 3

Author Comment

by:tyronenoel
ID: 36975878
apologies i didnt explain this correctly, it works in the front end it is just when you go into the administrators panel is when you get the error, i am going to try the following

Second, you could edit/create the file with the name .htaccess in your Document Root and add

php_value memory_limit 256M

ziceva i havent worked much in the .htaccess file, is there a specific place within the file i must insert the comment?

Thanks
0
 
LVL 5

Assisted Solution

by:lazysheepmedia
lazysheepmedia earned 1000 total points
ID: 36978102
You could putt he php.ini file in the root of your directory (site) or in the admin folder

The entry for the .htaccess file you can put at the end but remember to put a line space at the end of the file - please also make sure you have the dot at the beginning of the file name "."htaccess#

regards

Mark
0
 
LVL 5

Expert Comment

by:lazysheepmedia
ID: 36978108
also check to see if there is already an entry in the htaccess file already and change it accordingly
0
 
LVL 3

Author Closing Comment

by:tyronenoel
ID: 36984330
Hi Guys

I found the problem, it was a partially uploaded massive picture that had been uploaded, the .htaccess caused a 500 configuration error and the php.ini didnt work as my server host has allowoverride off

but i will award points as they were both valid answers
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will shed light on the latest trends when it comes to your resume building needs. For far too long, the traditional CV format has monopolized the recruitment market.
There is a massive demand for content on the web right now, and it doesn't look like it's going to stop any time soon. But, if you are running a business blog, it's not just enough to offer your audience lots of content. It needs to be high-quality…
The viewer will learn how to dynamically set the form action using jQuery.
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
Suggested Courses
Course of the Month18 days, 8 hours left to enroll

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question