• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 719
  • Last Modified:

Backup exec + MS-Exchange using GRT. Can't select the mailboxes/emails.

Hey,

So…I’m new to using Granular Recovery Technology for MS-Exchange via Backup Exec 2010.

I’m trying to do a test restore of an individual users mailbox and/or an email…but I can’t find how to select these ANYWHERE. The complete lack of documentation makes me think it’s so obvious that something on my system must be configured wrong.

So I have a couple of questions…
1.      Exactly, step-by-step, as if I were computer challenged - how/where do you select an individual’s email for restore?
2.      I’m fairly confident I have the Granularity setup correctly…
   a.      I have an Exchange mailbox setup for the BE user.
   b.      The BE user is a member of all the appropriate groups.
   c.      The exchange Mailbox Storage Groups are selected for backup
   d.      GRT is still (as by default) selected in the backup options through Tools | options | Microsoft Exchange | GRT
   e.      I have created a separate directory for the staging area
…SOOOO…how can I confirm if GRT is actally running (the default logs are showing no erros)

Thanks!
0
Mike R.
Asked:
Mike R.
  • 7
  • 3
1 Solution
 
Hypercat (Deb)Commented:
Exactly, step-by-step:

1.  Open Backup Exec and click the Restore/New Restore job option.
2.  On the Selections screen, select and expand the Exchange server name and expand Microsoft Information Store.
3.  Expand the mailbox database and then expand the backup date.
4.  Under the backup date, you should see the database name and when you expand that you should see each individual mailbox list.
5.  If you expand the mailbox you want to restore, you should also be able to see and select any individual folder and/or message(s) within the folders in that person's mailbox.

It's really as simple as that.  If you don't see the mailboxes listed, then you aren't doing a GRE backup.
0
 
Hypercat (Deb)Commented:
Sorry - I meant "GRT" not "GRE" :-)
0
 
Hypercat (Deb)Commented:
<< d.      GRT is still (as by default) selected in the backup options through Tools | options | Microsoft Exchange | GRT

I missed this on the first reading. You have to select the GRT option in the job template setup, not just in the Tools/Options settings in Backup Exec. Is it also specified in your backup job?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Mike R.Author Commented:
Hi HyperCat,

Thanks for the reply!! So...

1. Thats what I thought on the step-by-step. When I do that I DON'T see any folders or individual emails (see image)...so something is wrong with the backups.

2. I am using a policy with a single backup job (a full backup that runs every weekday night).
    I have GRT checked in the Job Template setup (Tools | Options | MS Exchange)
    I have GRT checked int he POLICY.
    I cannot find A PLACE within the backup job itself (as it appears in the bottom pane "Backup Selection Lists") where I can select GRT.

 BE selections Exchange
0
 
Mike R.Author Commented:
PS How do I increase the verbosity of the logs...and where would those logs end up...that I might see whats happening with the backup (I.e. see if the GRT is failing because of the user/pass, or something else :-)
0
 
Hypercat (Deb)Commented:
What version of Exchange are you using?
0
 
Hypercat (Deb)Commented:
Please post a capture of your selection list showing how you are selecting the Exchange information store and also a capture of the Exchange page of your backup policy so that I can see the settings.  Thanks!
0
 
Hypercat (Deb)Commented:
Just to be clear, what I'm seeing in the picture you posted (a Restore job, not the backup job) is what looks like a flat file backup, not a backup of the Exchange information store itself. So, I need to see your actual selection list for the backup job.

As for the verbosity setting on the logs, you need to go the Tools/Options menu in the main application window. Then click on Job Logs and set the verbosity level there.
0
 
Mike R.Author Commented:
Hey! Actually I got it working now :-) Your info was enough to help me figure out where I went wrong. In the backup I needed to select the "Microsoft Information Stores" as well as the actuall file data.

Now I can select individual mailboxes and emails.

I did get an error stating I needed to install the package "Microsoft Exchange Server MAPI Client and Collaboration Data Objects" (version 06.05.7888 or later) on the Exchange 2007 server.

I will do this later, and will post a separate question if I run into snags :-)

Thanks!
0
 
Hypercat (Deb)Commented:
That's great - that's where I was going with asking to see your selection list.  After looking at the picture you posted, it seemed that you perhaps didn't have the info store selected properly. Glad you got it sorted out!

Make sure you download the correct version of the MAPI/CDO update - for Exchange 2007 not 2010 - and you should be OK.  

Deb
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now