Issue viewing PDFs in IE 9 64bit Windows 7

The issue I am experiencing is related to viewing PDF documents embedded in websites using IE 9 64bit. I have no problems viewing embedded PDFs in IE 9 32bit, I only see the issue in the 64bit version. IE 64bit doesn't even have Adobe listed in the add-ons list and acts like reader isn't even installed. Here is what I have tried so far (restarting pretty much after every step):

Removed Adobe Reader X and installed 9.4
Removed IE 9 and installed 8
Did a fresh install of IE 9 and a fresh install of reader 10
Installed PDF viewers other than Adobe Reader
Used regsvr32 to register the activex controls manually

I really don't know what else to try here, has anyone experienced this issue or have any suggestions?


 
ITNCAsked:
Who is Participating?
 
Run5kCommented:
It's quite possible that there isn't an Adobe plugin to view PDF documents using the 64-bit version of Internet Explorer.  Typically, that's why most of us recommend against using IE9 64-bit.  Even though they finally have a Flash plugin available, there are still far too many things that aren't fully supported in that version.

Unless you have a compelling need to use IE9 64-bit, I would stick with the 32-bit version.
0
 
-tjsCommented:
Unfortuantely there are no versions of Acrobat compatible with 64-bit versions of Internet Explorer:
http://kb2.adobe.com/cps/328/328233.html
0
 
ded9Commented:
Try new user account...user profile might be corrupted.



Ded9
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
jcimarronCommented:
ITNC--Click  on the embedded .pdf file, chose Save As, and try to open from saved file.
0
 
Ivano ViolaSystem AdministratorCommented:
You can change the setting in Adobe Acrobat Reader so that PDF files open in the program instead of the web browser.

Edit - Preferences - Internet
Uncheck: Display PDF in browser.

This will allow you to view PDFs using both browsers (32/64-bit).

IV
0
 
ITNCAuthor Commented:
Not so much of a solution, more just an informative statement
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.