[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 712
  • Last Modified:

Exchange 2010 Calendar Permissions

We have just upgrade to exchange 2010. We have several rooms setup. We need all staff to be able to view these room calendars (schedules). It seems that they can views meeting but cannot open the meeting details to view any notes. In other words they have only top level (freeébusy) view. I have changed default permissions on the calendars but they do not seem to work for users. Even if I give default Publisher access as a test it still doesnèt not have any effect on users permissions. It seems that staff are not getting the default permission.

any ideas.....
0
j8547
Asked:
j8547
  • 7
  • 7
1 Solution
 
amenezes0617Commented:
You can set the calendar permissions via power shell with this command:


Set-MailboxFolderPermission -Identity room@domain.com:\Calendar -User Default -AccessRights LimitedDetails

Change room@domain.com to your room's email address.

0
 
j8547Author Commented:
I have done this and even done get permissions to make sure its set but when i try and open a calendar item I get cannot open free busy information. This happens for every permission level i change default to. So it seems like it is not setting it somewhere.
0
 
amenezes0617Commented:
Try logging into a computer as that room, creating an outlook profile and checking the calendar permissions to see if they are being set properly, according to the level you set with the command.
You have to enable the user account first, as they are disabled by default.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
j8547Author Commented:
I enables the account but you could only see extra permissions and not default one. still cannot get it to work.
0
 
amenezes0617Commented:
These are accounts that existed before the upgrade to 2010? If so I would setup a new one and see if it behaves the same way, perhaps something is wrong with the permissions.
Also, did you login and see the permissions via Outlook?
0
 
j8547Author Commented:
permissions are set correctly as I have tried via owa and I can view it correctly. just not in outlook
0
 
j8547Author Commented:
No they are all new accounts. didnèt login via outlook yet just owa.
0
 
amenezes0617Commented:
So are you saying that when you view the room's meetings via OWA you can see all the information you want, but when you see them via Outlook you can't?
Please clarify.
0
 
j8547Author Commented:
Yea that is exactly it. From having a look ont he internet it seems to be an issue with alot of people but no one has a solution.
0
 
amenezes0617Commented:
Can you post the results of your Get-MailboxFolderPermission command with all the permissions listed?
0
 
amenezes0617Commented:
If it works via OWA, can you try removing one Outlook from cached mode and see if it makes a difference?
0
 
j8547Author Commented:
I have attached but removed name of mailbox and a last one of a user and has nothignt o do with it.
mailbox.png
0
 
j8547Author Commented:
How do i do that, remove from cached mode...
0
 
amenezes0617Commented:
In Outlook 2010 go to File > Account Settings > Account Settings > Change unclick the box that says Use Cached Mode.
Close and reopen outlook. then try to view the meetings in the conference room.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now