Outlook Web Access will not work with SSL

Have an Exchange 2007 SP2 server on a Server 2003  that we cannot gain access to OWA over https.

I have already performed the following:

Recreate Server Certificate. (x4)
Recreated Virtual Directoy in IIS
Reinstalled CAS role.

None of this seems to work. I do know that I can access OWA if I uncheck SSL encryption, OWA will work. I still think this is Certificate related. Any help would be appreciated.
compunet1Asked:
Who is Participating?
 
compunet1Connect With a Mentor Author Commented:
Purchased third party certificate and imported.
0
 
Shreedhar EtteCommented:
- What is the error you get while accessing the OWA with SSL?
0
 
sumit_aroraCommented:
Are you able to access Default web site using SSL. Try https://localhost then https://localhost/OWA.
If none of the above is working then check https://Internal servername and  https://servername/owa
This could be certificate issue or machine key issue

Please follow this artcile and check permition on machine key folder

http://support.microsoft.com/kb/278381/en-us 

Try to install the self sign certificate and check if none of the above help you to resolve your issue
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
compunet1Author Commented:
Sumit,

I am unable to access the website at all under any possible way with SSL turned on for the owa site in IIS. I checked those permissions and had to change the settings to what was listed in the article. This did not resolve the issue. I have already installed self signed certificate. We are going to get a cert from GoDaddy to try and alleviate. There have been issues in the past with the self signed certs on this server.
0
 
sumit_aroraCommented:
Yes, if it worked with self sign that means issue was with Certificate. that why i aske you to check with self sign certificate :-)
0
 
compunet1Author Commented:
It isnt working with 3rd party Cert either.
0
 
sumit_aroraCommented:
checked the binding on the default web site is showing 443 and any other site in IIS should not be running on port 443
0
 
compunet1Author Commented:
Resolved on my own
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.