• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2070
  • Last Modified:

RED HAT 6 mkswap "Device or resource busy"

I created a new 2gb partition sdd1.  I then run mkswap to make a second swap partition (the first is on sda).  I get "Device or resource busy".
0
drj003
Asked:
drj003
  • 2
1 Solution
 
Paul CoffeyCommented:
Is it mounted or otherwise in use?  Does the -f option allow it to work?
0
 
Hugh McCurdyCommented:
To test if it's mounted, type

# mount

You might try rebooting.
0
 
Hugh McCurdyCommented:
Are you sure you tried to "format" the correct partition?  Is it tagged as 82?

I wonder if something automounted it as a Windows partition (if it was already setup for Windows).
0
 
drj003Author Commented:
It wasn't mounted or otherwise in use that I could tell.  The -f option did work though.  Any idea why it didn't work without the force option?

Thanks for your replies.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now