Cannot logon sbs 2008 with domain admin

Hi guys!

I cant logon my sbs 2008. Everything seems to work but I just cant log in with domain admin on the server.
I have tried to reboot the server with no luck.
When I try to log on im getting stuck at policy drive maps policy, then it wont get any longer. The server continues to work and the clients doesnt notice anything.
I was on vacation when the problems started so nothing special has been done with the server last 2 weeks that I know of.
When I use computer management to connect to the server I see a lot of DistributedCOM errors with event id 10009 in the system log. Around 3 of them errors every minute.

I might be missing some information you need in order to help me. Just tell me if what you need to know and ill answer.

Hope someone can help me out here, thanks in advance.
anvendarnamnAsked:
Who is Participating?
 
Sushant GulatiConnect With a Mentor ConsultantCommented:
Leave the DCOM 10009 that's due to stale entries in the DNS. Some machines IP changed and the DNS still had the entries and the protocol tries to communicate with these registered machines.

Make sure to do the Block Inheritance on that OU so that this domain admin would not inherit any domain policies for mapping drives or printers or what so ever. If this admin needs a map drive then you can certainly use the login script and place under his account object in the Active Directory Users and Computers.

For the DCOM errors 10009..

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_27113866.html

Good Luck..!! Sorry for the late reply..
~SG~
0
 
Sushant GulatiConsultantCommented:
Download RSAT tools. You can install it on Windows 7 machine. Open up GPMC and check the mapped drives GPO. Unlink the Group Policy and reboot the Windows SBS 2008 server and see you are able to login with the Domain Admin on the console of the server or not.

Good Luck..!!
~SG~
0
 
Sushant GulatiConsultantCommented:
Here is the link from where you can download...

http://www.microsoft.com/download/en/details.aspx?id=7887
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
anvendarnamnAuthor Commented:
So I tried Admintools but couldnt connect to the server that way either.
Ended up shutting the server down on the powerbutton since I couldnt even use the shutdown command from command prompt. Hate doing that but didnt have enough time and I have backups..
After I shutdown the server and then booted it up again I still had a similar problem. This time it didnt stop at drive maps though. It stopped right before, think its "configuring group policy something."
Got stuck there for 30mins but decided to just let it keep going since all the services worked and so on. Got back a couple of hours later and could log on!!! :)
Logged in and moved the domain admin into a newly created ou. I dont have time to investigate this more in a couple of days so cant really tell you what was wrong with the ou I had domain admin in.

The DistributedCOM errors was a couple of computer we have removed but didnt remove from AD.

Thanks for the quick answers anyways susguperf!
0
 
James HIT DirectorCommented:
You didn't by chance disable IPv6?
SBS requires this to be active and not disabled.
0
 
anvendarnamnAuthor Commented:
Thank you for the nice information mate!
0
 
anvendarnamnAuthor Commented:
BTW, I didnt disable IPv6. But thanks anyways..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.