• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 782
  • Last Modified:

Mapped Drives with red X

Hi,

I'm using just a batch file including the "net use" command to map the drives.

For some odd reasons, some of the mapped drives have big red X mark on them - see attached file.

But when you click on the mapped drive with red X mark, it disappears and appears normal again just like the other active ones.

Appreciate any feedback.

0
mcse2007
Asked:
mcse2007
2 Solutions
 
BAmillerCommented:

This a known issue (by design) with Microsoft Server Products where drives are mapped across a LAN. In MS's infinite wisdom, they decided to code a "time-out" period in which mapped drives would go dormant if not accessed within "x" amount of time.  It is supposed to save on network resources.  - I forget what the default time period is, but it can be configured to almost anything, or you can turn it off completely.

I turned it OFF on my local computer as follows:

Run regedit.exe

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\
Set or create a DWORD (32-bit) and name it:

RestoreConnection

then set its Hexadecimal value to 0

Restart and voila! Problem solved, the mapped drives will not connect until you access them for the first time, but will never "time out" again.

If that does not help, another possible solution is to configure the “EnableLinkedConnections” registry value as follows:

Run regedit then right-click the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Right-click anywhere in the white screen and choose "new" DWORD (32-bit) Value
Type EnableLinkedConnections, and then press Enter.
Right-click the newly created EnableLinkedConnections, and then click Modify.
In the hexadecimal Value data box, type 1, and then click OK.
Exit Registry Editor and then restart the computer.

In order to apply this fix globally, you can apply the registry key via Group Policy in Server 2008 under Computer Configuration\Preferences\Windows Settings\Registry.  In here I right-clicked in the white space and clicked New > Registry entry, and filled out the fields.  This has worked across our LAN to all W7 clients without issue.

Hope this helps.
0
 
John HurstBusiness Consultant (Owner)Commented:
You can also just ignore it. The red X has been going on a long time and  is by desgn as noted above. As long as (for you above and for me / my clients) the folder works normally when clicked, then there is no need for concern.  

... Thinkpads_User
0
 
mcse2007Author Commented:
Thanks
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now