How do I get Outlook Anywhere to work on Mac OS 10.7?

There must be a trick to get Outlook Anywhere to sync and connect to our server remotely. We are running Exchange Sever 2007 on a Microsoft Server 2008.

My problem only appears on our new Macs with Outlook 2011 for the Mac. We have six new computers, so I need to figure this out. I thought it had something to do with our self-signed certificate. But, I applied the certificate to the keychain and still doesn't work. Am I attaching it to the wrong part of the keychain? There is the option of applying it to login or system and maybe one other option. Also, I set up a Mac for a user back in July and her Outlook Anywhere is working! But, she is the only one! (out of 11 computers)

I'm stumped and need some input. Thanks!
razzyritaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Instead of beating your head against the wall with Outlook, why not just use the native Mac Mail which configures very easily to an Exchange server (2007 or newer)?

http://hosting.intermedia.net/support/kb/default.asp?id=1791
0
mikeewaltonCommented:
* Outlook Anywhere: The self-signed certificate cannot be used with Outlook Anywhere. We recommend that you obtain a certificate from a Windows PKI or a trusted commercial third party if you will be using Outlook Anywhere.

from:   http://technet.microsoft.com/en-us/library/bb851554(EXCHG.80).aspx

As cheap as they are, I couldn't imagine using a self signed over public.

0
razzyritaAuthor Commented:
To strung: I am tired of hitting my head against the wall on this, but I couldn't get Mac Mail to work either. We have already purchased the Outlook software, so I think I'd prefer getting this to work.

To Mikeewalton: I know that Microsoft says that the self-signed certificate won't work, but it does work on one of our computers - which has Snow Leopard 10.6. I also stopped to talk to the Apple Genius Bar and a guy there told me it should work with the self-signed certificate. The Genius Bar guy said that it would work better with a shared secret for the VPN (instead of a certificate authentication), but when I talked to our IT guy about it, he had no idea. He doesn't remember setting one up.

My IT guy seems to think that we can get VPN to work though the software NetExtender. And he's partially correct. I can connect to the VPN. But I still cannot access the server. I'm getting the error message, "There was a problem connecting to the server "192.168.0.3". This file server is available on your computer. Access the volumes and files locally.

The Apple Genius guy told me to set up a VPN through Network in the System Preferences. I tried everything I could think of and still it won't let me connect.

So how cheap is a Windows PKI or a trusted commercial third party certificate? I'm not sure that I can convince my boss that we need to spend hundreds of dollars on this.

Thank for your help.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

razzyritaAuthor Commented:
I think my comments might not make a whole lot of sense, because I have two questions I'm working on. One problem is getting Outlook Anywhere to work and the other is getting the VPN to work. Are they related? The Mac guy said that once I get the VPN to work, Outlook Anywhere will work too. I'm kind of skeptical though...
0
strungCommented:
The problem with the VPN is likely that both the local and remote LANs are using the same subnet and the Mac then can't tell whether 192.168.0.3 is local or remote.

Change to the local LAN subnet to, say 192.168.5.x and that should solve the VPN problem.
0
razzyritaAuthor Commented:
I am new at this, so not sure I did it right. I changed the IP setting under Network - Advanced Tab/TCP/IP tab. Maybe I did it in the wrong place?

At any rate, the error message I get is telling me that I don't have a certificate. But, I do have one installed on the keychain. The other option you have is using a shared secret, which my IT guy had no idea about.
Screen-Shot-2011-10-23-at-1.32.4.png
0
strungCommented:
Exactly what setting did you change? You can't just change the IP address on the client machine if you are trying to change the subnet on the local lan if that is what you were trying to do. This has to be done by changing the settings on your home router.
0
razzyritaAuthor Commented:
I was changing the setting on the client machine. I don't have a home router, only a modem.
0
strungCommented:
What is the Local IP address of your computer? You can find it by checking the Network prefs. You may have to change settings on your modem if it is acting as a router.
0
razzyritaAuthor Commented:
The IP address is 192.168.0.2. I don't know that I can change settings on my modem. The thing is, I am setting up this laptop for use by another user. I have already set up the same MacBook Pros for three new users and they are all experiencing problems connecting to Outlook Anywhere from home. These laptops will be used around town at various locations/coffee shops, etc. So, it needs to work from everywhere, not just my home. I also tried connecting from the Apple Store and couldn't get that to work either.
0
strungCommented:
The VPN won't work to connect to a remote LAN using the same subnet as the local LAN. Unfortunately, 192.168.0.x is the default used by some router manufacturers and likely you have the same router at home as at the office and that is why the have the same subnet.

The ideal solution would be to change the office subnet to one not commonly used as the default by router manufacturers.

If, for instance, you were to change your office subnet LAN to 192.168.20.x, which I doubt is used by any router manufacturers as the default, you will likely find that your client computers can connect by VPN from anywhere.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
razzyritaAuthor Commented:
This makes sense and sounds like a possible solution. However, why would my PC at home, using the same modem work just fine and the Mac OS 10.7 Lion will not work?
0
strungCommented:
I really don't know why Macs have that problem, but they do. Something different about the way the implement VPN.
0
razzyritaAuthor Commented:
It turns out you were correct. My home modem/router was on the same subnet as the NetExtender software that operates with the SonicWall VPN device. Once I changed my Qwest router to a manually configured new IP address, it worked! The VPN is quite a bit slower on the Mac than the PC, but that's another problem. I'll have to open a new question.

Sorry I doubted your advice. Also, the original question on this thread was solved when I looked at the Outlook settings on a laptop I set up a few months ago. I had entered a local address instead of an address with https:// address in the server settings.

Thanks so much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.