?
Solved

Exchange and iPhone Attachment Size

Posted on 2011-10-15
10
Medium Priority
?
4,402 Views
Last Modified: 2012-05-12
Has anyone had issues with iPhone activesync with Exchange server and attachment size issues?
Got a client with an Exchange 2003 and 2010 server, in the middle of a migration.  The problem is that only the iPhones cannot send attachments over 10mb.  The droids can and of course the Blackberry's can (BES 5 server)  The Exchange servers are patched fully.  
Currently, all activesync users are on the 2003 server.  Took one user and moved them to the 2010 server to test but same results.  Attachment sizes on both Exchange servers are set to 25mb and sending over 10mb can happen from Outlook at the desktop.

When sending (forwarding mostly) the iPhone looks like its syncing and reads sending for about 6 minutes then fails.

Thanks for any input.
0
Comment
Question by:RFloyd30
  • 5
  • 3
  • 2
10 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36976195
Your iPhones are probably hitting the default 10mb restriction set on the Exchange 2010 server now, so please increase the Receive settings according to the following article:

http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html

The article is for 2007, but the settings apply to 2010 too.
0
 

Author Comment

by:RFloyd30
ID: 36976241
Thank you for the reply - However, I don't think that is the issue.  I mean, why would it only effect the iPhones and not droids or Outlook clients or OWA clients?
I will review all the settings on the server.  Thank you.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36976254
Humour me and try it please.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 

Author Comment

by:RFloyd30
ID: 36977322
Thanks alanhardisty - we have again went over all settings on the 2010 server.
We have checked the Global settings, the send connectors, the receive connector and the individual mailboxes in question.  all are set to 25mb or larger.  Including the activesync policy under the organization which has no check and thus I assume no limit.  Am i missing something?

Thanks again.
0
 

Accepted Solution

by:
RFloyd30 earned 0 total points
ID: 36977606
Problem solved...at least on the 2010 server.  Will not know for 2003 server users until tomorrow.

This is the exact issue with the fix.

http://dougg.co.nz/2011/05/25/event-id-1008-maximum-request-length-exceeded/

A simple change to the web.config file...  since 2003 does not have a CAS like 2007/2010, i made the change in the c:\program files\exchange\activesync folder and appended the string with my figures.

Thanks for help anyway.  I hope this can help others, too.
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 36986620
On the same lines, E2k3 wont have any web.config

If someone still face the same issues w.r.to the E2k3 or IIS6.0
Then check for the presence of the "URLScan"

Note: Ensure that urlscan.ini shouldn't be there in the system.
0
 

Author Comment

by:RFloyd30
ID: 36990342
Actually there is a web.config on Exchange 2k3.  It is located at C:\Program Files\Microsoft Exchange ActiveSync Administration folder.  At least on this one.

The string did not exist in that file so I appended the URL cmd - saved and iisreset.

Not to say it had any affect because I changed both the 2010 server and the 2003 server at the same time.  We successfully tested attachments on iphones with mailboxes on both servers over 10mb.

0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36991144
Thanks everyone for posting updates to this question - it will be very helpful for future searchers.
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 36991163
I double checked my E2k3,IIS6.0 servers

Regarding the Microsof-server-activesync
Local Path: C:\Program Files\Exchsrvr\OMA\Sync
The content is empty

OMA:
Local Path: C:\Program Files\Exchsrvr\OMA\Browse
yes, this path should have the web.config

IMO, this web.config should affect\control just the OMA access and not the Microsoft-server-ActiveSync communication

0
 

Author Closing Comment

by:RFloyd30
ID: 37035370
Solved the problem.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
You finally migrated Public Folders to Office 365, decommissioned the Public Folder mailbox database and since then, when you send an email from on-premise to mail-enabled Public Folders, you get the following error: "Misconfigured public folder mai…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question