is IonCube error pointing to symlink

Can't determine if I'm a noob or a boob (or both), but this has be stymied.

I'm trying to install IonCube 5.2 on a  Virtual Private Server (Linux x86)

The first time I ran the installer using IonCube's MS Windows installer. This seems to have converted the directory at /usr/local/php into s symlink to /usr/local/php-5.2.14/.

Here is a grab of the FTP showing the directory with the little arrow on the PHP directory. Screen Grab of Filezilla Directory
I then tried creating the missing directory and loading the tar.gz file to it. Now I get the following error: IonCube Wizard error
According to this, the correct file is in the /usr/local/php/ directory and needs to be moved to the /usr/local/php-5.2.14/ directory.

But when I click on the local/php directory, I'm taken directly to the local/php-5.2.14 directory.

Please try and straighten me out. I've already crashed a couple of sites and got myself into quite a jam.
LVL 26
David BruggeAsked:
Who is Participating?
 
PapertripConnect With a Mentor Commented:
Are you sure that /usr/local/php is now a symlink to /usr/local/php-5.2.14 ?  I don't see that directory in your attachments, I do see php-5.3.8 however.

Login to the Linux server and do 'ls -l /usr/local/php'

Basically it sounds like /usr/local/php is pointing to php-5.3.8, and that directory has the loader, but your config file says to look in /usr/local/php-5.2.14 which doesn't appear to exist per your screenshots.  Wherever that is set, change it to /usr/local/php and leave the version out, let the symlink take care of that.

0
 
Computer GuyCommented:
The best way to install ionCube is to just get the file you need (Linux version), http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.zip

make a directory on the server called ioncube, and upload the file.

Then reference the path in your php.ini file.

Remember if using Zend, that ioncube needs to go first.
0
 
PapertripCommented:
The loader file already exists on his system, he just needs to fix the paths.
0
 
David BruggeAuthor Commented:
Thanks. After ruining several websites panic starts to set in. I overlooked that I was pointing to a non-existent directory. That is why it is always good to have a fresh set of eyes.

thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.