[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 319
  • Last Modified:

Default Page not appearing on web site

Hi folks,

    I have a website, http://www.thejourneyofbear.com and when I go to the web site, the default page, (default.html)  does not appear, yet it is fine on my test computer. If I enter the url,http://www.thejourneyofbear.com/default.html, it will appear. This is not right!
    Is there something I need to do to my web config file? All but one of my pages are html pages and their is only one page that is aspx page (an input form for users). How can I fix this?
Do I need to compile my project and what does compiling do anyhow? I am very new to asp.net..sigh
0
Overthere
Asked:
Overthere
  • 2
1 Solution
 
Rajkumar GsSoftware EngineerCommented:
Did you have 'Default.html' set in IIS ? - If not, try add it

Raj
0
 
Rajkumar GsSoftware EngineerCommented:
0
 
BAmillerCommented:
As a temporary test, try renaming "default.html" to "index.html" and see if that works.  

It is a good idea to use index.html or index.htm on most servers, as default.htm(l) is most often used on Windows Servers and is just not as common as it used to be.

While I see that the GoDaddy Server hosting your domain is configured for Windows Server 2008 / Microsoft-IIS/7.0 – try to rename the file as a first line of defense.   Also, make sure that you do NOT have FrontPage Extensions enabled at GoDaddy as this is NOT compatible with IIS-7.

Let’s try this first, and see if this works . . .
0
 
OverthereAuthor Commented:
Okay, I will try it and let you know soon.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now