Problem with GBIC uplink

dear Sir,
i bought new GBIC for my old switch WS-C3524-XL and when i installed it the switch didnt dedicate it and didnt appear on the show running? so please advise what i should do to make it work

the below is the show versipon of the switch
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.3)WC(1), MAINTENANCE
 INTERIM SOFTWARE
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 30-Apr-01 07:51 by devgoyal
Image text-base: 0x00003000, data-base: 0x003331F4

ROM: Bootstrap program is C3500XL boot loader

6th_floor3524 uptime is 1 day, 3 hours, 2 minutes
System returned to ROM by power-on
System image file is "flash:c3500XL-c3h2s-mz.120-5.3.WC.1.bin"


cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes
of memory.
Processor board ID FAB0522V24N, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
23 FastEthernet/IEEE 802.3 interface(s)
1 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:06:28:8E:A9:00
Motherboard assembly number: 73-3904-11
Power supply part number: 34-0851-02
Motherboard serial number: FAB0521105A
Power supply serial number: PHI050905ED
Model revision number: A0
Motherboard revision number: B0
Model number: WS-C3524-XL-EN
System serial number: FAB0522V24N
Configuration register is 0xF
shareef_yassinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John MeggersNetwork ArchitectCommented:
The GBIC is really just a media converter, it shouldn't should show up in the configuration.  Is the interface properly configured and no-shut?
0
Istvan KalmarHead of IT Security Division Commented:
please provide us:
sh int status
sh diag
0
shareef_yassinAuthor Commented:
6th#show interfaces status

Port    Name               Status       Vlan     Duplex Speed   Type
------- ------------------ ------------ -------- ------ ------- ----
Fa0/1                      notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/2                      notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/3                      connected    60       A-Full   A-100 100BaseTX/FX
Fa0/4                      notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/5                      notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/6                      connected    1        A-Full   A-100 100BaseTX/FX
Fa0/7                      connected    60       A-Full   A-100 100BaseTX/FX
Fa0/8                      connected    60       A-Full   A-100 100BaseTX/FX
Fa0/9                      connected    60       A-Full   A-100 100BaseTX/FX
Fa0/10                     notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/11                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/12                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/13                     notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/14                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/15                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/16                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/17                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/18                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/19                     notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/20                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/21                     connected    1        A-Full   A-100 100BaseTX/FX

Port    Name               Status       Vlan     Duplex Speed   Type
------- ------------------ ------------ -------- ------ ------- ----
Fa0/22                     connected    60       A-Full   A-100 100BaseTX/FX
Fa0/23                     notconnect   1          Auto    Auto 100BaseTX/FX
Fa0/24                     notconnect   1          Auto    Auto 100BaseTX/FX
Gi0/1                      connected    trunk    A-Full    1000 CX_GIGASTACK

the G0/2 doesnt appear in the abvoe show

6th#show diag link-flap
Interface                 Total   Last Min
-------------------- ---------- ----------
FastEthernet0/3               4          0
FastEthernet0/6               2          0
FastEthernet0/7              10          0
FastEthernet0/8               2          0
FastEthernet0/9              12          0
FastEthernet0/11              9          0
FastEthernet0/12              1          0
FastEthernet0/14             11          0
FastEthernet0/15              5          0
FastEthernet0/16              6          0
FastEthernet0/17              4          0
FastEthernet0/18              6          0
FastEthernet0/20              9          0
FastEthernet0/21              4          0
FastEthernet0/22              2          0
GigabitEthernet0/1            3          0

and the below is the show interface status for other switch the G0/2 apprear normal
#show interfaces status

Port    Name               Status       Vlan     Duplex Speed   Type
------- ------------------ ------------ -------- ------ ------- ----
Gi0/1                      connected    trunk    A-Full    1000 1000BASESX
Gi0/2                      connected    trunk    A-Full    1000 CX_GIGASTACK

0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Istvan KalmarHead of IT Security Division Commented:
It seems, there is a problem with the switch, did you tried to upgrade the ios?
0
shareef_yassinAuthor Commented:
no,bcz i have the same IOS and working fine in other switch
0
Istvan KalmarHead of IT Security Division Commented:
in this case it is a hardware error... did you tried to change the slots of the gbics?
0
shareef_yassinAuthor Commented:
yes and i face the same problem i tried it in the working one now and it doesnt work too
0
Istvan KalmarHead of IT Security Division Commented:
reloading?
0
shareef_yassinAuthor Commented:
i did the reload and not update
0
j_mnemonicCommented:
Do not appears any error message during boot process?.

I usually check a lot of differents GBIC modules connecting it on Cisco devices and, in my experience, the switch show error message if the GBIC module is not compatible or if is defective.

Sorry my poor english.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shareef_yassinAuthor Commented:
ok i will check with the reboot, but there is no log appear after it starts
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.