• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 281
  • Last Modified:

cisco routing: cant ping from one cisco to the other

i have two cisco 1701's connecting a point-to-point T1
 i am having trouble pinging from the upstream router to the ip address of the downstream one (i can ping the serial interfaces between the two with no problem)

so, from upstream to downstream, this fails
 ping 192.168.2.252
 (traceroute shows the packets 'flapping' between the two serial interfaces)

upstream router:

 interface FastEthernet0
description Ethernet connection to Hanceville LAN
 ip address 12.208.238.195 255.255.255.192 secondary
 ip address 192.168.23.252 255.255.255.0
 speed auto full-duplex
 no cdp enable
!
interface Serial0
description connected to smithlake
ip address 192.168.103.1 255.255.255.252
encapsulation ppp
 no fair-queue
service-module t1 clock source internal
service-module t1 timeslots 1-24
no cdp enable
 !
ip classless
 ip route 0.0.0.0 0.0.0.0 192.168.23.254
ip route 192.168.2.0 255.255.255.0 192.168.103.2
 !

downstream:
interface FastEthernet0
description connected to ethernetLAN
ip address 192.168.22.254 255.255.255.0 secondary
ip address 192.168.2.252 255.255.255.0
speed auto full-duplex
!
 interface Serial0
 ip address 192.168.103.2 255.255.255.252
encapsulation ppp
no fair-queue
service-module t1 timeslots 1-24
no cdp enable
 !
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.103.1
ip http server
 !
0
jimwarrenus
Asked:
jimwarrenus
  • 4
  • 3
1 Solution
 
SouljaCommented:
On the upstream,

no ip route 0.0.0.0 0.0.0.0 192.168.23.254
ip route 0.0.0.0 0.0.0.0 192.168.103.2
no ip route 192.168.2.0 255.255.255.0 192.168.103.2


Downstream looks fine. Give that a try.




0
 
jimwarrenusAuthor Commented:
additional info.....

i got a switch installed for the lan port at the downstream cisco... and now i can ping it from the upstream router...and as far as that goes from the upstream lan......

but,

i am failing to reach the internet from the downstream cisco...

from the upstream cisco, i can reach internet addresses.....but from the downstream one i can reach the router above the cisco, but it seems to die there

from the outside :
att router   xx.xx.xx.193
----netgear router (does nat, etc)   xx.xx.xx.194 (gateway is the .193 address on the att router)

lan is 192.168.23.0/24, netgear is 192.168.23.254

two static routers on netgear--

192.168.103.0
255.255.255.252
gateway    192.168.23.252
metric 3

and,

192.168.2.0
255.255.255.0
gateway   192.168.23.252
metric 3
0
 
jimwarrenusAuthor Commented:

---- but the upstream is the way out to the internet (thru 192.168.23.254)
i would not be able to go anywhere, would i?

Soulja: said:

On the upstream,

no ip route 0.0.0.0 0.0.0.0 192.168.23.254
ip route 0.0.0.0 0.0.0.0 192.168.103.2
no ip route 192.168.2.0 255.255.255.0 192.168.103.2

Downstream looks fine. Give that a try.

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
SouljaCommented:
My first comment was under the assumption that we were dealing with just the two routers. You didn't mention the other router or connecting to the internet in your question. That being said keeps the routes that I said the delete, and your setup should work.  The only think that you may need to change is the metric for the 192.168.2.0 network. It should be higher than the other route.
0
 
SouljaCommented:
Otherwise, I don't see why it shouldn't be working.
0
 
jimwarrenusAuthor Commented:

i set the metric on 192.168.2.0 network  to 6......   still seeing same problem
0
 
jimwarrenusAuthor Commented:
turns out i switched the netgear router to another netgear model, put same settings in and it worked.........sheesh

thanks for the help and confirmation
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now