Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

adding registry value on remote machine

I'm using the following to add a value and data to the Run key on a remote machine:

reg add \\192.168.1.11\HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion /v test /d 123
The operation completed successfully.
but when opening that key using the regedit on the remote machine, the value and data is not there.

also, when using the same command again, I see the following question:
Value test exists, overwrite(Yes/No)?

???
0
OrenRozen
Asked:
OrenRozen
1 Solution
 
peter197911Commented:
When you open regedit and connect to a network register (192.168.1.11)
you do see the added registry then?

0
 
OrenRozenAuthor Commented:
no.
0
 
V4705Commented:
Hi Oren,

1. You need to make sure "remote registry" service is running.
2. I would specify the type (/t) also in the command.
3. Personally I'm using psexec by sysinternals for remote commands, works great.


Good luck!
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
OrenRozenAuthor Commented:
1. the service is running. (I can connect from my pcto the remote machine using regedit)
2. /t didn't solve the problem
3. I'm trying to avoid external applications.
0
 
KenMcFCommented:
If these are domain computers you can use Group Policy Pref. to set the registry values.


http://www.windowsitpro.com/article/registry2/q-is-there-an-easy-way-to-change-a-registry-setting-on-specific-servers-
0
 
OrenRozenAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for OrenRozen's comment http:/Q_27399268.html#36976322

for the following reason:

I had 2 problems.<br />The first was solved with your first suggestion to start the service.<br />The second problem was my mistake in spelling.<br /><br />Thanks for the help.
0
 
OrenRozenAuthor Commented:
closed my own comment by mistake.
would like to post same reply and point to V4705:
0
 
OrenRozenAuthor Commented:
Sorry. Closed on my own comment by mistake.

I had 2 problems.
The first was solved with your first suggestion to start the service.
The second problem was my mistake in spelling.

Thanks for the help.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now