Backup and Restore: V2V vs V2P issues

Posted on 2011-10-17
Last Modified: 2012-08-13
I have been trying to test restores with the CommVault and figure out if our data is good enough to restore a whole system from for production purposes. I have tried restoring individual files and smaller amounts of data to physical and virtual file servers without any issues, but it has been larger amounts of data restoring to a virtual file server that has been giving me grief. Until I get this seemingly simple flat file restore figured out, I am not going to even try to do huge SQL database or mess around with anything else. My company runs in a highly virtualized environment and the majority of our production servers are VMs running in a Hyper-V environment. We do have some VMware Cisco servers and sooner than later, some OracleVM will be rolling into the mix with our new ERP that will also need to be put onto our new CommVault system.

My problem so far is that any file restore to a VM that lasts longer than 15 to 16 minutes will time out and say that it lost a connection with the media agent. I tried restoring a couple terabytes a VM that runs off of one of our SANs and it continuously did this like clockwork. It would run the restore for maybe 15:22 one time and then disconnect. It would wait for about 45 minutes and restart only to do this again. If you can imagine the restore job took a while, but it did finally finish. The only error it had upon completion was for 1 file that did seem to have some kind of an issue that was legitimate. I restored the exact same data to a physical server and it did not quit or pause even once and everything seemed fine.

So, this leads me to my question, can someone please tell me what your experiences have been with something similar to this? It seems to me that the CommVault may not intentionally differentiate between virtual and physical machines in regard to restores, but is this actually the case? I know that there is such a thing as the virtual server heartbeat being different than the physical server’s and is there some kind of settings change that needs to be made? Perhaps we are going about this incorrectly, but it is assumed that the media agent can be installed onto a VM in the same way that it is installed on to a physical machine running the server. Backups seem to go ok, but not restores. Is there a VM to host ratio that is a good idea to stay under in regard to successful CommVault functionality?

I know that this is really a broad topic in the world of data centers, but I’m certain that I am not the first to be dealing with this. Any guidance and help is greatly appreciated since this whole system is really challenging me no matter what I seem to try. The seemingly random errors lead to blank pages on the support site and web searches haven’t brought me much help. YouTube videos that I have found are all seemingly informational marketing videos

Question by:tervis
    LVL 12

    Expert Comment

    how did u backup in the first instance, normal file idagents or using snap protect backups!

    Author Comment

    Sorry for the lengthy background and question. We are using the iDataAgents for Windows Filesystem, SQL Server, Virtual Servers and Exchange. The initial configuration of the system did not involve using any snap protect backups with the QSnap agents. Do you have any reccomendation on using the QSnap agents?

    Accepted Solution

    This issue seemingly resolved itself after we upgraded to Simpana 9 SP4.

    Author Closing Comment

    This issue seemingly resolved itself after we upgraded to Simpana 9 SP4.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Microservice architecture adoption brings many advantages, but can add intricacy. Selecting the right orchestration tool is most important for business specific needs.
    OfficeMate Freezes on login or does not load after login credentials are input.
    This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
    This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now