[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 576
  • Last Modified:

Installing MySql in Fedora 11

Hi experts,
               
                          I have downloaded MySql MySQL-5.5.16-1.linux2.6.i386 and tried to install using rpm command it failed

Regards,
Vimal.
0
vimalalex
Asked:
vimalalex
  • 13
  • 11
1 Solution
 
amarjitsCommented:
why dont u just try this:

yum install mysql-server

it will automatically install the current version.

hope it helps :)
0
 
vimalalexAuthor Commented:
Hi experts,

                    I have typed rpm -i MySQL-server-5.5.16-1.linux2.6.i386.rpm in terminal and the following error messages printed. The error messages are as folloes
      
file /usr/share/mysql/charsets/README from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/Index.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/armscii8.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/ascii.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp1250.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp1251.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp1256.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp1257.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp850.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp852.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/cp866.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/dec8.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/geostd8.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/greek.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/hebrew.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/hp8.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/keybcs2.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/koi8r.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/koi8u.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/latin1.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/latin2.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/latin5.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/latin7.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/macce.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/macroman.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/charsets/swe7.xml from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/danish/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/dutch/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/english/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/estonian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/french/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/german/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/greek/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/hungarian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/italian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/japanese/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/korean/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/norwegian-ny/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/norwegian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/polish/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/portuguese/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/romanian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/russian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/serbian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/slovak/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/spanish/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/swedish/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
      file /usr/share/mysql/ukrainian/errmsg.sys from install of MySQL-server-5.5.16-1.linux2.6.i386 conflicts with file from package mysql-libs-5.1.32-1.fc11.i586
0
 
simoespCommented:
you have to remove first mysql-client and mysql-libs to install the mysql-server 5.5

try
rpm -e  mysql-libs-5.1.32-1.fc11.i586
first before installing mysql-server
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
vimalalexAuthor Commented:
Hi amarjits,
      I tried yum install mysql-server.

installation failed with following error


Transaction Check Error:
  file /usr/share/man/man1/msql2mysql.1.gz from install of mysql-server-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlbinlog.1.gz from install of mysql-server-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlcheck.1.gz from install of mysql-server-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlimport.1.gz from install of mysql-server-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/msql2mysql from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_find_rows from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_waitpid from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlaccess from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqladmin from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlbinlog from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlcheck from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqldump from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlimport from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlshow from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlslap from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlslap.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_config from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.1.47-1.fc11.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386

Thanks & Regards,
Vimal
0
 
vimalalexAuthor Commented:
Hi simoesp:

     I tried rpm -e  mysql-libs-5.1.32-1.fc11.i586 but it failed.


rpm -e  mysql-libs-5.1.32-1.fc11.i586
error: Failed dependencies:
      libmysqlclient.so.16 is needed by (installed) redland-1.0.7-6.fc11.i586
      libmysqlclient.so.16 is needed by (installed) php-mysql-5.2.9-2.fc11.i586
      libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) redland-1.0.7-6.fc11.i586
      libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) php-mysql-5.2.9-2.fc11.i586

Thanks & regrads,
Vimal.
0
 
simoespCommented:
do
rpm -qa |grep MySQL
rpm -qa |grep mysql

and dump the lists over here
0
 
vimalalexAuthor Commented:
Hi simoesp,

 rpm -qa |grep MySQL
MySQL-client-5.5.16-1.linux2.6.i386
MySQL-devel-5.5.16-1.linux2.6.i386
MySQL-embedded-5.5.16-1.linux2.6.i386

rpm -qa |grep mysql
php-mysql-5.2.9-2.fc11.i586
mysql-libs-5.1.32-1.fc11.i586

Thanks & Regards,
Vimal.
0
 
simoespCommented:
check this site

http://www.if-not-true-then-false.com/2010/install-mysql-on-fedora-centos-red-hat-rhel/

try to install remy and epel for your fedora 11

then try yum install mysql-server
0
 
vimalalexAuthor Commented:
Hi simoesp,

  I am unable to read http://www.if-not-true-then-false.com/2010/install-mysql-on-fedora-centos-red-hat-rhel/  contents of site is there any other site for this

Thanks & Regards,
Vimal.
0
 
simoespCommented:
hello vimal,

i've pasted a resume of what you'll have todo

## Remi Dependency on Fedora 15, 14, 13, 12, 11, 10, 9, 8
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm 
rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

## Fedora 11 ##
rpm -Uvh http://rpms.famillecollet.com/remi-release-11.rpm


yum --enablerepo=remi install mysql mysql-server
0
 
vimalalexAuthor Commented:
Hi simoesp,

              I tried your above instructions but it failed with the following errors

Transaction Check Error:
  file /usr/bin/mysql from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/msql2mysql from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_find_rows from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_waitpid from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlaccess from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqladmin from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlbinlog from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlcheck from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqldump from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlimport from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlshow from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysqlslap from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlslap.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/msql2mysql.1.gz from install of mysql-server-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlbinlog.1.gz from install of mysql-server-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlcheck.1.gz from install of mysql-server-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysqlimport.1.gz from install of mysql-server-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-client-5.5.16-1.linux2.6.i386
  file /usr/bin/mysql_config from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386

Thanks & Regards,
vimal.
0
 
simoespCommented:
yum remove MySQL-client-5.5.16-1.linux2.6.i386 MySQL-devel-5.5.16-1.linux2.6.i386

then
yum --enablerepo=remi install mysql mysql-server
0
 
vimalalexAuthor Commented:
Hi simoesp,

                I think some other mysql version is in my machine how can I remove completly from my machine.

Thanks,
Vimal.
0
 
simoespCommented:
read previous post =)
0
 
simoespCommented:
yum remove MySQL-embedded-5.5.16-1.linux2.6.i386

too
0
 
vimalalexAuthor Commented:
Hi simoesp,

              I tried that command it is failing

[root@Vimal bin]# rpm -e  mysql-libs-5.1.32-1.fc11.i586
error: Failed dependencies:
      libmysqlclient.so.16 is needed by (installed) redland-1.0.7-6.fc11.i586
      libmysqlclient.so.16 is needed by (installed) php-mysql-5.2.9-2.fc11.i586
      libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) redland-1.0.7-6.fc11.i586
      libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) php-mysql-5.2.9-2.fc11.i586

Thanks,
Vimal.
0
 
vimalalexAuthor Commented:
Hi simoesp,

                Is there any other solution to solve this problem.

Thanks,
Vimal.
0
 
simoespCommented:
rpm -e --nodeps mysql-libs-5.1.32-1.fc11.i586 MySQL-embedded-5.5.16-1.linux2.6.i386 MySQL-client-5.5.16-1.linux2.6.i386

ten try to install the
yum --enablerepo=remi install mysql mysql-server
0
 
vimalalexAuthor Commented:
HI simoesp,

                    I tried the above and get this error

[root@Vimal bin]# yum --enablerepo=remi install mysql mysql-server
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.i586 0:5.5.16-1.fc11.remi set to be updated
--> Processing Dependency: mysql-libs(x86-32) = 5.5.16-1.fc11.remi for package: mysql-5.5.16-1.fc11.remi.i586
---> Package mysql-server.i586 0:5.5.16-1.fc11.remi set to be updated
--> Processing Dependency: perl-DBI for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Processing Dependency: perl(DBI) for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Running transaction check
---> Package mysql-libs.i586 0:5.5.16-1.fc11.remi set to be updated
---> Package perl-DBD-MySQL.i586 0:4.010-1.fc11 set to be updated
--> Processing Dependency: libmysqlclient.so.16 for package: perl-DBD-MySQL-4.010-1.fc11.i586
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: perl-DBD-MySQL-4.010-1.fc11.i586
---> Package perl-DBI.i586 0:1.607-2.fc11 set to be updated
--> Running transaction check
---> Package compat-mysql51.i586 0:5.1.54-1.fc11.remi set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
 Package                              Arch                       Version                                     Repository                    Size
================================================================================================================================================
Installing:
 mysql                                i586                       5.5.16-1.fc11.remi                          remi                         7.6 M
 mysql-server                         i586                       5.5.16-1.fc11.remi                          remi                          13 M
Installing for dependencies:
 compat-mysql51                       i586                       5.1.54-1.fc11.remi                          remi                         1.8 M
 mysql-libs                           i586                       5.5.16-1.fc11.remi                          remi                         1.1 M
 perl-DBD-MySQL                       i586                       4.010-1.fc11                                fedora                       171 k
 perl-DBI                             i586                       1.607-2.fc11                                fedora                       782 k

Transaction Summary
================================================================================================================================================
Install       6 Package(s)
Upgrade       0 Package(s)

Total size: 24 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/bin/mysql_config from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386
  file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.5.16-1.fc11.remi.i586 conflicts with file from package MySQL-devel-5.5.16-1.linux2.6.i386

Error Summary
-------------

Thanks,
Vimal
0
 
simoespCommented:
rpm -e --nodeps MySQL-devel-5.5.16-1.linux2.6.i386

yum --enablerepo=remi install mysql mysql-server mysql-devel
0
 
vimalalexAuthor Commented:
Hi simoesp,

                The above commands you have given is succeded is there any thing to do for completing installation .Thank you very much for your fast response


[root@Vimal bin]# rpm -e --nodeps MySQL-devel-5.5.16-1.linux2.6.i386
[root@Vimal bin]# yum --enablerepo=remi install mysql mysql-server mysql-devel
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.i586 0:5.5.16-1.fc11.remi set to be updated
--> Processing Dependency: mysql-libs(x86-32) = 5.5.16-1.fc11.remi for package: mysql-5.5.16-1.fc11.remi.i586
---> Package mysql-devel.i586 0:5.5.16-1.fc11.remi set to be updated
---> Package mysql-server.i586 0:5.5.16-1.fc11.remi set to be updated
--> Processing Dependency: perl-DBI for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Processing Dependency: perl(DBI) for package: mysql-server-5.5.16-1.fc11.remi.i586
--> Running transaction check
---> Package mysql-libs.i586 0:5.5.16-1.fc11.remi set to be updated
---> Package perl-DBD-MySQL.i586 0:4.010-1.fc11 set to be updated
--> Processing Dependency: libmysqlclient.so.16 for package: perl-DBD-MySQL-4.010-1.fc11.i586
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: perl-DBD-MySQL-4.010-1.fc11.i586
---> Package perl-DBI.i586 0:1.607-2.fc11 set to be updated
--> Running transaction check
---> Package compat-mysql51.i586 0:5.1.54-1.fc11.remi set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
 Package                              Arch                       Version                                     Repository                    Size
================================================================================================================================================
Installing:
 mysql                                i586                       5.5.16-1.fc11.remi                          remi                         7.6 M
 mysql-devel                          i586                       5.5.16-1.fc11.remi                          remi                         174 k
 mysql-server                         i586                       5.5.16-1.fc11.remi                          remi                          13 M
Installing for dependencies:
 compat-mysql51                       i586                       5.1.54-1.fc11.remi                          remi                         1.8 M
 mysql-libs                           i586                       5.5.16-1.fc11.remi                          remi                         1.1 M
 perl-DBD-MySQL                       i586                       4.010-1.fc11                                fedora                       171 k
 perl-DBI                             i586                       1.607-2.fc11                                fedora                       782 k

Transaction Summary
================================================================================================================================================
Install       7 Package(s)
Upgrade       0 Package(s)

Total size: 25 M
Total download size: 174 k
Is this ok [y/N]: y
Downloading Packages:
mysql-devel-5.5.16-1.fc11.remi.i586.rpm                                                                                  | 174 kB     00:05    
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

WARNING : This MySQL RPM is not an official Fedora/Redhat build and it
overrides the official one. Don't file bugs on Fedora Project nor Redhat.
Use dedicated forums http://forums.famillecollet.com/

WARNING : Fedora 11 is now EOL :
You should consider upgrading to a supported release.

  Installing     : mysql-libs-5.5.16-1.fc11.remi.i586                                                                                       1/7
  Installing     : mysql-5.5.16-1.fc11.remi.i586                                                                                            2/7
  Installing     : perl-DBI-1.607-2.fc11.i586                                                                                               3/7
  Installing     : compat-mysql51-5.1.54-1.fc11.remi.i586                                                                                   4/7
  Installing     : mysql-devel-5.5.16-1.fc11.remi.i586                                                                                      5/7
  Installing     : perl-DBD-MySQL-4.010-1.fc11.i586                                                                                         6/7
  Installing     : mysql-server-5.5.16-1.fc11.remi.i586                                                                                     7/7

Installed:
  mysql.i586 0:5.5.16-1.fc11.remi            mysql-devel.i586 0:5.5.16-1.fc11.remi            mysql-server.i586 0:5.5.16-1.fc11.remi          

Dependency Installed:
  compat-mysql51.i586 0:5.1.54-1.fc11.remi mysql-libs.i586 0:5.5.16-1.fc11.remi perl-DBD-MySQL.i586 0:4.010-1.fc11 perl-DBI.i586 0:1.607-2.fc11

Complete!

Thanks,
Vimal
0
 
simoespCommented:
;)
0
 
vimalalexAuthor Commented:
Hi simoesp,

               I am new to mysql in linux how can I start mysql and use mysql client to connect with mysql

Thanks,
Vimal
0
 
simoespCommented:
service mysqld start

will start the service

and

mysql will connect to mysql

take a look at the pdf

u got there some points of interest
Install-MySQL-5.5.16-on-Fedora-1.pdf
0
 
vimalalexAuthor Commented:
Hi simoesp,

                      Thank you for your excellent,excellent... help.

Thanks,
Vimal.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 13
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now